summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2009-01-30 00:16:41 +0100
committerMichael Adam <obnox@samba.org>2009-01-30 00:17:56 +0100
commita44649cf98ea8f45537ff9a65be69d621c002505 (patch)
tree2571941727b284d369da54f3ae6db1da529bafac /source3/configure.in
parent37da26a06ee0a51f2e6c7b93e2fefc2342613c84 (diff)
downloadsamba-a44649cf98ea8f45537ff9a65be69d621c002505.tar.gz
samba-a44649cf98ea8f45537ff9a65be69d621c002505.tar.bz2
samba-a44649cf98ea8f45537ff9a65be69d621c002505.zip
s3:build: fix build on AIX - only test for splice on linux
Michael
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f44fb9b8c4..87707a2f7f 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -5875,6 +5875,8 @@ fi
############################################
# See if we have the Linux splice syscall.
+case "$host_os" in
+*linux*)
AC_CACHE_CHECK([for Linux splice],
samba_cv_HAVE_LINUX_SPLICE,[
AC_TRY_LINK([
@@ -5885,6 +5887,11 @@ AC_CACHE_CHECK([for Linux splice],
[long ret = splice(0,0,1,0,400,0);],
samba_cv_HAVE_LINUX_SPLICE=yes,
samba_cv_HAVE_LINUX_SPLICE=no)])
+;;
+*)
+samba_cv_HAVE_LINUX_SPLICE=no
+;;
+esac
if test x"$samba_cv_HAVE_LINUX_SPLICE" = x"yes"; then
AC_DEFINE(HAVE_LINUX_SPLICE,1,