summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-09-23 01:48:45 +0000
committerJeremy Allison <jra@samba.org>1998-09-23 01:48:45 +0000
commitaab2fe021643417854451c65e564932f4ac25f10 (patch)
tree2377d1c7ea68759507f471beb1ab1d101a067552 /source3/configure.in
parent3b7cee95ac741ee24b8edd36095cc30e3377a23c (diff)
downloadsamba-aab2fe021643417854451c65e564932f4ac25f10.tar.gz
samba-aab2fe021643417854451c65e564932f4ac25f10.tar.bz2
samba-aab2fe021643417854451c65e564932f4ac25f10.zip
First cut at kernel oplocks. This should have no effect unless runnin
on a machine that supports them in autoconf. Move various functions out of lib/util.c into smbd/process.c and smbd/oplock.c where they belong. Jeremy. (This used to be commit c3c5e13f85c97939746070132dad941e79c546fb)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4b30d5470b..80f93a3b1a 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -277,6 +277,15 @@ if test x"$samba_cv_HAVE_UTIMBUF" = x"yes"; then
AC_DEFINE(HAVE_UTIMBUF)
fi
+AC_CACHE_CHECK([for kernel oplock type definitions],samba_cv_HAVE_KERNEL_OPLOCKS,[
+AC_TRY_COMPILE([#include <sys/types.h>
+#include <fcntl.h>],
+[oplock_stat_t t; t.os_state = OP_REVOKE; t.os_dev = 1; t.os_ino = 1;],
+samba_cv_HAVE_KERNEL_OPLOCKS=yes,samba_cv_HAVE_KERNEL_OPLOCKS=no)])
+if test x"$samba_cv_HAVE_KERNEL_OPLOCKS" = x"yes"; then
+ AC_DEFINE(HAVE_KERNEL_OPLOCKS)
+fi
+
AC_MSG_CHECKING([for test routines])
AC_TRY_RUN([#include "${srcdir-.}/tests/trivial.c"],