summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAlexandre Oliva <oliva@samba.org>1998-09-21 11:34:44 +0000
committerAlexandre Oliva <oliva@samba.org>1998-09-21 11:34:44 +0000
commitac39ce3eba28eed97942e915f7b4cd77cdfd9e2d (patch)
tree0d1a85c8a7cb40edc812ae51b0fd9dee94bcff00 /source3/configure.in
parente649750cb4d2d2577f0577b1d7a87ae4daf8fb6f (diff)
downloadsamba-ac39ce3eba28eed97942e915f7b4cd77cdfd9e2d.tar.gz
samba-ac39ce3eba28eed97942e915f7b4cd77cdfd9e2d.tar.bz2
samba-ac39ce3eba28eed97942e915f7b4cd77cdfd9e2d.zip
replace getpass() with getsmbpass() if getsmbpass.c compiles
(This used to be commit 9a5bdf5c1bef689fe0d6879949df869efbc34783)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 99224b66a0..4b30d5470b 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -298,6 +298,21 @@ if test x"$samba_cv_HAVE_BROKEN_GETGROUPS" = x"yes"; then
AC_DEFINE(HAVE_BROKEN_GETGROUPS)
fi
+AC_CACHE_CHECK([whether getpass should be replaced],samba_cv_REPLACE_GETPASS,[
+SAVE_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$CPPFLAGS -I${srcdir-.}/include -I${srcdir-.}/ubiqx"
+AC_TRY_COMPILE([
+#define REPLACE_GETPASS 1
+#define NO_CONFIG_H 1
+#define main dont_declare_main
+#include "${srcdir-.}/lib/getsmbpass.c"
+#undef main
+],[],samba_cv_REPLACE_GETPASS=yes,samba_cv_REPLACE_GETPASS=no)
+CPPFLAGS="$SAVE_CPPFLAGS"
+])
+if test x"$samba_cv_REPLACE_GETPASS" = x"yes"; then
+ AC_DEFINE(REPLACE_GETPASS)
+fi
AC_CACHE_CHECK([for broken inet_ntoa],samba_cv_REPLACE_INET_NTOA,[
AC_TRY_RUN([