summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vlendec@samba.org>2007-05-05 22:47:07 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:21:46 -0500
commitbaabe03030ad4b3320fae80b4aab0db4f38fe7a0 (patch)
tree194afb246252d859fbc9221fc4af4097bd2f9032 /source3/configure.in
parentfb5644342760cb54b4285c65ab36d693f558a289 (diff)
downloadsamba-baabe03030ad4b3320fae80b4aab0db4f38fe7a0.tar.gz
samba-baabe03030ad4b3320fae80b4aab0db4f38fe7a0.tar.bz2
samba-baabe03030ad4b3320fae80b4aab0db4f38fe7a0.zip
r22692: Fix compilation of explicit --without-winbind.
Thanks to Tom Bork for reporting this! Volker (This used to be commit 3f956d345143f64f57c02419eb8494c6ed51ce59)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index a334a48183..19f0a2e511 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -5925,10 +5925,6 @@ AC_SUBST(WINBIND_NSS_EXTRA_OBJS)
AC_SUBST(WINBIND_NSS_EXTRA_LIBS)
AC_SUBST(NSSSONAMEVERSIONSUFFIX)
-if test $BLDSHARED = true -a x"$HAVE_WINBIND" = x"yes"; then
- NSS_MODULES="${WINBIND_NSS} ${WINBIND_WINS_NSS}"
-fi
-
AC_SUBST(SMB_KRB5_LOCATOR)
# Check the setting of --with-winbind
@@ -5963,6 +5959,10 @@ if test x"$HAVE_WINBIND" = x"no"; then
WINBIND_WINS_NSS=""
fi
+if test $BLDSHARED = true -a x"$HAVE_WINBIND" = x"yes"; then
+ NSS_MODULES="${WINBIND_NSS} ${WINBIND_WINS_NSS}"
+fi
+
if test x"$HAVE_WINBIND" = x"yes"; then
AC_MSG_RESULT(yes)
AC_DEFINE(WITH_WINBIND,1,[Whether to build winbind])