summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2007-06-09 00:10:26 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:23:13 -0500
commitbde0642ab43b92b780bd60cc889116154110c878 (patch)
tree3644f24ead02a3bc05d9cdf9d687432263896959 /source3/configure.in
parent0ae0d33a3a396cfbd540a86a8c7384cb075bfe0c (diff)
downloadsamba-bde0642ab43b92b780bd60cc889116154110c878.tar.gz
samba-bde0642ab43b92b780bd60cc889116154110c878.tar.bz2
samba-bde0642ab43b92b780bd60cc889116154110c878.zip
r23398: Support membership of >16 groups on Darwin by making sure we opt in to the
dynamic group resolution mechanism when switching UNIX credentials. (This used to be commit b5cb21e951550fe836b0ef5febc037af9a7f51ec)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index be92a9144d..d69a40eb90 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3100,6 +3100,21 @@ if test x"$samba_cv_USE_SETUIDX" = x"yes"; then
fi
fi
+AC_CACHE_CHECK([for the Darwin initgroups system call],
+ samba_cv_DARWIN_INITGROUPS,
+ AC_TRY_LINK([
+#include <sys/syscall.h>
+#include <unistd.h>
+ ],
+ [ syscall(SYS_initgroups, 16, NULL, NULL, 0); ],
+ samba_cv_DARWIN_INITGROUPS=yes,
+ samba_cv_DARWIN_INITGROUPS=no)
+)
+
+if test x"$samba_cv_DARWIN_INITGROUPS" = x"yes" ; then
+ AC_DEFINE(HAVE_DARWIN_INITGROUPS, 1,
+ [Whether to use the Darwin-specific initgroups system call])
+fi
AC_CACHE_CHECK([for working mmap],samba_cv_HAVE_MMAP,[
AC_TRY_RUN([#include "${srcdir-.}/tests/shared_mmap.c"],