summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2000-12-07 06:23:01 +0000
committerJeremy Allison <jra@samba.org>2000-12-07 06:23:01 +0000
commitc31211167bc2b98f51f8f3cc70bb410250b427aa (patch)
tree3f744dd1ada7eef42c501a6a001fdda0d9303cbf /source3/configure.in
parent607c384aa55fb61b02e72217938616feecc322ac (diff)
downloadsamba-c31211167bc2b98f51f8f3cc70bb410250b427aa.tar.gz
samba-c31211167bc2b98f51f8f3cc70bb410250b427aa.tar.bz2
samba-c31211167bc2b98f51f8f3cc70bb410250b427aa.zip
Added better configure test for POSIX ACLs. Fixed stupid typo in sysacls.c
Jeremy. (This used to be commit da6ae57501e3cb971e82eac5bb05efcd9cf443ae)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in15
1 files changed, 12 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 252c6d7006..4b6119c9ef 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1934,9 +1934,18 @@ AC_ARG_WITH(posix-acls,
--without-posix-acls Don't include POSIX ACL support (default)],
[ case "$withval" in
yes)
- AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_POSIX_ACLS)
- ;;
+
+ AC_CHECK_LIB(acl,acl_get_file)
+AC_CACHE_CHECK([for POSIX ACL support],samba_cv_HAVE_POSIX_ACLS,[
+AC_TRY_COMPILE([#include <sys/types.h>
+#include <sys/acl.h>],
+[ acl_t acl; int entry_id; acl_entry_t *entry_p; return acl_get_entry( acl, entry_id, entry_p);],
+samba_cv_HAVE_POSIX_ACLS=yes,samba_cv_HAVE_POSIX_ACLS=no)])
+if test x"$samba_cv_HAVE_POSIX_ACLS" = x"yes"; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_POSIX_ACLS)
+fi
+ ;;
*)
AC_MSG_RESULT(no)
;;