summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMartin Pool <mbp@samba.org>2001-12-20 04:01:44 +0000
committerMartin Pool <mbp@samba.org>2001-12-20 04:01:44 +0000
commitcc0846f967f268764bff280f64d5cb47b716d796 (patch)
treed277e685bd3b8da1ecc6128176728eb3b41cafa3 /source3/configure.in
parent6c7e9dfb293f1243d9d8d8a2ac50ef12d738198e (diff)
downloadsamba-cc0846f967f268764bff280f64d5cb47b716d796.tar.gz
samba-cc0846f967f268764bff280f64d5cb47b716d796.tar.bz2
samba-cc0846f967f268764bff280f64d5cb47b716d796.zip
Add --enable-dmalloc to link against the dmalloc malloc debugger.
It's not as strong as Insure, but it's free, reasonably efficient and works on every platform. (This used to be commit e76d27fcdb33df5212ca5b0ce53c77ed8ca58906)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index e9665adbcc..48057c15a5 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -33,6 +33,14 @@ AC_ARG_ENABLE(developer, [ --enable-developer turn on developer warnings a
CFLAGS="${CFLAGS} -g -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -DDEBUG_PASSWORD -DDEVELOPER"
fi])
+AC_ARG_ENABLE(dmalloc, [ --enable-dmalloc enable heap debugging [default=no]])
+
+if test "x$enable_dmalloc" = xyes
+then
+ AC_DEFINE(ENABLE_DMALLOC, 1, [Define to turn on dmalloc debugging])
+ LIBS="$LIBS -ldmalloc"
+fi
+
dnl Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL