summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2002-04-04 05:47:41 +0000
committerTim Potter <tpot@samba.org>2002-04-04 05:47:41 +0000
commitfbbc63f93ca75f6e4835e56217a912d65660bc91 (patch)
treed727675570356b3d366d961f783f0bb935bca589 /source3/configure.in
parent0227568209c83e1789a056b14932520d280d2c2f (diff)
downloadsamba-fbbc63f93ca75f6e4835e56217a912d65660bc91.tar.gz
samba-fbbc63f93ca75f6e4835e56217a912d65660bc91.tar.bz2
samba-fbbc63f93ca75f6e4835e56217a912d65660bc91.zip
Use m4-mode when editinging configure.in under emacs.
Use $CC instead of $SHLD for the "test whether building a shared library actually works". At the moment this is failing as $SHLD (and $LDSHFLAGS - look at the value this is set to for Solaris) are designed to be used from a Makefile and not within configure so this test will always fail! Tridge has suggested moving to libtool^H^H^H^H^H a shell script that invokes the right linker with the right args and solves this problem nicely. (This used to be commit 4caf71d5b28e003133bacca153278478d8245989)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 014e321af2..ddb3e7109d 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1,3 +1,4 @@
+dnl -*- mode: m4-mode -*-
dnl Process this file with autoconf to produce a configure script.
AC_INIT(include/includes.h)
AC_CONFIG_HEADER(include/config.h)
@@ -819,7 +820,7 @@ AC_CACHE_CHECK([whether building shared libraries actually works],
ac_cv_shlib_works=no
# try building a trivial shared library
$CC $CPPFLAGS $CFLAGS $PICFLAG -c -o shlib.po ${srcdir-.}/tests/shlib.c &&
- $SHLD $CPPFLAGS $CFLAGS $LDSHFLAGS -o shlib.so shlib.po &&
+ $CC $CPPFLAGS $CFLAGS $LDSHFLAGS -o shlib.so shlib.po &&
ac_cv_shlib_works=yes
rm -f shlib.so shlib.po
])