summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-11-19 22:37:33 +0000
committerJeremy Allison <jra@samba.org>1998-11-19 22:37:33 +0000
commit17590be23d342259578d87c3d9310824863a5137 (patch)
treedbefbb9bbb006b3b330876d40ec32292b27a893a /source3/configure.in
parentd174f2ce57279404632a35684d2dc90b76cbddab (diff)
downloadsamba-17590be23d342259578d87c3d9310824863a5137.tar.gz
samba-17590be23d342259578d87c3d9310824863a5137.tar.bz2
samba-17590be23d342259578d87c3d9310824863a5137.zip
Sync up with 2.0 code.
Added HPUX autoconf changes. Added "gross hack" printer code. Jeremy. (This used to be commit 1ef6d3bd63722afe9c376793a6ea72046d1a0602)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 8c214ce9e5..0a3195199e 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -25,6 +25,16 @@ AC_CANONICAL_SYSTEM
AC_VALIDATE_CACHE_SYSTEM_TYPE
SAMBA_MAINTAINER_MODE
+# try to work out if this compiler uses the HPUX -Ae flag.
+case "$host_os" in
+ *hpux*)
+ AC_PROG_CC_FLAG(Ae)
+ if test $ac_cv_prog_cc_Ae = yes; then
+ CPPFLAGS="$CPPFLAGS -Ae"
+ fi
+ ;;
+esac
+
AC_INLINE
AC_HEADER_STDC
AC_HEADER_DIRENT
@@ -205,6 +215,15 @@ if test x"$ac_cv_func_set_auth_parameters" = x"no"; then
AC_DEFINE(HAVE_SET_AUTH_PARAMETERS)])
fi
+#
+# This next check is needed for HPUX,
+# again, shouldn't hurt anywhere else.
+#
+if test x"$ac_cv_func_getspnam" = x"no"; then
+ AC_CHECK_LIB(sec, getspnam, [LIBS="$LIBS -lsec";
+ AC_DEFINE(HAVE_GETSPNAM)])
+fi
+
# this bit needs to be modified for each OS that is suported by
# smbwrapper. You need to specify how to created a shared library and
# how to compile C code to produce PIC object files