summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>1998-10-23 01:51:31 +0000
committerAndrew Tridgell <tridge@samba.org>1998-10-23 01:51:31 +0000
commit1e60cc49f5ecb864ab965a6e7ab9287e1204d1d6 (patch)
tree13e6192365213c9b01c2577d675eebf76279ad36 /source3/configure.in
parent8c87f61e998182753817dfa6c0527bae70a54704 (diff)
downloadsamba-1e60cc49f5ecb864ab965a6e7ab9287e1204d1d6.tar.gz
samba-1e60cc49f5ecb864ab965a6e7ab9287e1204d1d6.tar.bz2
samba-1e60cc49f5ecb864ab965a6e7ab9287e1204d1d6.zip
don't enable smbsh/smbwrapper on systems where we can't work out how
to generate PIC code (This used to be commit a66c56d70e7e663f3a19cbfcc2e704653d8fc9b2)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 7cbfe0efa6..284b721f3c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -9,6 +9,7 @@ AC_SUBST(SHELL)
AC_SUBST(MPROGS)
AC_SUBST(LDSHFLAGS)
AC_SUBST(HOST_OS)
+AC_SUBST(WRAP)
AC_SUBST(WRAP32)
AC_SUBST(PICFLAG)
AC_PROG_AWK
@@ -70,6 +71,13 @@ if test x$PICFLAG = x; then
fi
fi
+# we can only support smbsh and smbwrapper if we can produce PIC code
+if test x$PICFLAG = x; then
+ echo No support for PIC code - disabling smbwrapper and smbsh
+ WRAP=""
+else
+ WRAP="bin/smbsh bin/smbwrapper.so"
+fi
AC_INLINE
AC_HEADER_STDC