summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vl@samba.org>2011-05-04 15:48:27 +0200
committerVolker Lendecke <vl@samba.org>2011-05-04 16:11:30 +0200
commit3f68b43dd56b8f338a18074741162bf6437ae78d (patch)
tree8ef23222cbba1a7f49fba1933c081ca9ae01dc72 /source3/configure.in
parent41bde55821a6c18ace24330aede8d4928215e658 (diff)
downloadsamba-3f68b43dd56b8f338a18074741162bf6437ae78d.tar.gz
samba-3f68b43dd56b8f338a18074741162bf6437ae78d.tar.bz2
samba-3f68b43dd56b8f338a18074741162bf6437ae78d.zip
vfs_gpfs: Properly notify the offline->online changes
This needs to be a separate module that cooperates with vfs_gpfs. If aio_fork is used early in the module chain it (correctly) does not propagate the aio ops down, so vfs_gpfs does not see them. This slim module must come early in the chain for notifies to work properly.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 67c440d118..f9263f6e82 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1117,6 +1117,7 @@ AC_CHECK_HEADERS(gpfs_gpl.h)
if test x"$ac_cv_header_gpfs_gpl_h" = x"yes"; then
AC_DEFINE(HAVE_GPFS,1,[Whether GPFS GPL headers are available])
default_shared_modules="$default_shared_modules vfs_gpfs"
+ default_shared_modules="$default_shared_modules vfs_gpfs_hsm_notify"
fi
#############################################
@@ -6882,6 +6883,7 @@ SMB_MODULE(vfs_cacheprime, \$(VFS_CACHEPRIME_OBJ), "bin/cacheprime.$SHLIBEXT", V
SMB_MODULE(vfs_prealloc, \$(VFS_PREALLOC_OBJ), "bin/prealloc.$SHLIBEXT", VFS)
SMB_MODULE(vfs_commit, \$(VFS_COMMIT_OBJ), "bin/commit.$SHLIBEXT", VFS)
SMB_MODULE(vfs_gpfs, \$(VFS_GPFS_OBJ), "bin/gpfs.$SHLIBEXT", VFS)
+SMB_MODULE(vfs_gpfs_hsm_notify, \$(VFS_GPFS_PREFETCH_OBJ), "bin/gpfs_hsm_notify.$SHLIBEXT", VFS)
SMB_MODULE(vfs_readahead, \$(VFS_READAHEAD_OBJ), "bin/readahead.$SHLIBEXT", VFS)
SMB_MODULE(vfs_tsmsm, \$(VFS_TSMSM_OBJ), "bin/tsmsm.$SHLIBEXT", VFS)
SMB_MODULE(vfs_fileid, \$(VFS_FILEID_OBJ), "bin/fileid.$SHLIBEXT", VFS)