summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>1998-11-14 23:52:49 +0000
committerAndrew Tridgell <tridge@samba.org>1998-11-14 23:52:49 +0000
commit62725d1c5cd7f96488854adf2feb5a0c28f2a120 (patch)
tree5ed309a36da7f2ced7281389f4a8d1224b6c1139 /source3/configure.in
parent6b989ca4fd6e80e04a28ccea76875933f016dd86 (diff)
downloadsamba-62725d1c5cd7f96488854adf2feb5a0c28f2a120.tar.gz
samba-62725d1c5cd7f96488854adf2feb5a0c28f2a120.tar.bz2
samba-62725d1c5cd7f96488854adf2feb5a0c28f2a120.zip
compile with optimisation by default on all compilers
this has 2 effects: 1) non gcc platforms get some optimisation 2) it disables -g by default which means the samba binaries won't be so huge (they were over 60MB on some systems) (This used to be commit 263b13222c14db7ddec1430132c6362be4442147)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 65c31d434f..178d566c80 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -10,6 +10,10 @@ AC_SUBST(HOST_OS)
AC_SUBST(WRAP)
AC_SUBST(WRAP32)
AC_SUBST(PICFLAG)
+
+# compile with optimisation and without debugging by default
+CFLAGS=${CFLAGS-"-O"}
+
dnl Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL