summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorBjörn Jacke <bj@sernet.de>2010-05-29 01:40:21 +0200
committerBjörn Jacke <bj@sernet.de>2010-05-30 16:25:28 +0200
commit96ee9568eddf1a2f80ed5beb916ad00b1e2710bd (patch)
treeaf7910d0e44c8c6c6faf7a5c13ffd894e381e6a5 /source3/configure.in
parentb869350ddda84d0d6953339843bebd25d18b8fba (diff)
downloadsamba-96ee9568eddf1a2f80ed5beb916ad00b1e2710bd.tar.gz
samba-96ee9568eddf1a2f80ed5beb916ad00b1e2710bd.tar.bz2
samba-96ee9568eddf1a2f80ed5beb916ad00b1e2710bd.zip
s3: fix check for pie compiler flags
some compilers (HP and Sun e.g.) output warning messages on stderr for unknown options and we ended up partly using some unwanted random compile flags we did't intend to use.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 387e382dde..630421ab45 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1498,9 +1498,9 @@ then
[
cat > conftest.c <<EOF
int foo;
-main () { return 0;}
+int main () { return 0;}
EOF
- if AC_TRY_COMMAND([${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS -pie -fPIE -o conftest conftest.c 1>&AS_MESSAGE_LOG_FD])
+ if AC_TRY_COMMAND_NO_STDERR([${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS -pie -fPIE -o conftest conftest.c])
then
samba_cv_fpie=yes
else