summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>1998-07-29 07:02:06 +0000
committerAndrew Tridgell <tridge@samba.org>1998-07-29 07:02:06 +0000
commita957abd1fd1bd891354abb1a3590627ae06a45e9 (patch)
treeae38b5da1b37971a96970c9df5211fc4e9e95814 /source3/configure.in
parent13e351d123789ad38736da9435590f9188f5b66f (diff)
downloadsamba-a957abd1fd1bd891354abb1a3590627ae06a45e9.tar.gz
samba-a957abd1fd1bd891354abb1a3590627ae06a45e9.tar.bz2
samba-a957abd1fd1bd891354abb1a3590627ae06a45e9.zip
test for a broken inet_ntoa and replace it if necessary (for
IRIX+gcc-2.8.1) (This used to be commit ddffbcbcb1284b6ead5f7f7b6665ba2456c0071a)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 5cdc3425d6..a7cba67688 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -217,6 +217,19 @@ AC_TRY_RUN([#include "tests/getgroups.c"],
echo no)
+echo $ac_n "checking for broken inet_ntoa ... $ac_c"
+AC_TRY_RUN([
+#include <stdio.h>
+#include <sys/types.h>
+#include <netinet/in.h>
+#include <arpa/inet.h>
+main() { struct in_addr ip; ip.s_addr = 0x12345678;
+if (strcmp(inet_ntoa(ip),"18.52.86.120") &&
+ strcmp(inet_ntoa(ip),"120.86.52.18")) { exit(0); }
+exit(1);}],
+ echo yes;AC_DEFINE(REPLACE_INET_NTOA),
+ echo no)
+
echo $ac_n "checking for root ... $ac_c"
AC_TRY_RUN([main() { exit(getuid() != 0); }],
echo yes;AC_DEFINE(HAVE_ROOT),