summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGünther Deschner <gd@samba.org>2006-04-11 16:57:16 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:15:59 -0500
commitc8fabfbf1919da16e16ec3e998aa0e8ccd9ed0d3 (patch)
treedbc11043f84b0f9ab11462e0d3ca6bd394468a10 /source3/configure.in
parent655b04e4f8585a952afe226e602995ebbc7d1600 (diff)
downloadsamba-c8fabfbf1919da16e16ec3e998aa0e8ccd9ed0d3.tar.gz
samba-c8fabfbf1919da16e16ec3e998aa0e8ccd9ed0d3.tar.bz2
samba-c8fabfbf1919da16e16ec3e998aa0e8ccd9ed0d3.zip
r15043: Only build our copy of iniparser when the system doesn't have one.
Guenther (This used to be commit 5ae22cf46b1077b8892a2941a2891fe7412f1b9f)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in37
1 files changed, 37 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f21ee2faa8..1aa4adf4f0 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -5314,6 +5314,43 @@ AC_SUBST(POPTLIBS)
AC_SUBST(FLAGS1)
#################################################
+# Check to see if we should use the included iniparser
+
+AC_ARG_WITH(included-iniparser,
+[ --with-included-iniparser use bundled iniparser library, not from system],
+[
+ case "$withval" in
+ yes)
+ INCLUDED_INIPARSER=yes
+ ;;
+ no)
+ INCLUDED_INIPARSER=no
+ ;;
+ esac ],
+)
+if test x"$INCLUDED_INIPARSER" != x"yes"; then
+ AC_CHECK_LIB(iniparser, iniparser_load,
+ INCLUDED_INIPARSER=no, INCLUDED_INIPARSER=yes)
+fi
+
+AC_MSG_CHECKING(whether to use included iniparser)
+if test x"$INCLUDED_INIPARSER" = x"yes"; then
+ AC_MSG_RESULT(yes)
+ BUILD_INIPARSER='$(INIPARSER_OBJ)'
+ INIPARSERLIBS='$(INIPARSER_OBJ)'
+ FLAGS1="$FLAGS1 -I$srcdir/iniparser/src"
+else
+ AC_MSG_RESULT(no)
+ BUILD_INIPARSER=""
+ INIPARSERLIBS="-liniparser"
+fi
+AC_SUBST(BUILD_INIPARSER)
+AC_SUBST(INIPARSERLIBS)
+AC_SUBST(FLAGS1)
+
+
+
+#################################################
# Check if the user wants Python
# At the moment, you can use this to set which Python binary to link