summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-10-15 00:55:17 +0000
committerJeremy Allison <jra@samba.org>1998-10-15 00:55:17 +0000
commitfc7d3e4caa7650c02ef36fff83b64b06050f66b1 (patch)
tree8fbe7f4ec700a5f2f42397683783e7d19249337a /source3/configure.in
parentbc747b8a077d22344aa03bbba202f5137b59284d (diff)
downloadsamba-fc7d3e4caa7650c02ef36fff83b64b06050f66b1.tar.gz
samba-fc7d3e4caa7650c02ef36fff83b64b06050f66b1.tar.bz2
samba-fc7d3e4caa7650c02ef36fff83b64b06050f66b1.zip
config: Fix crypt prototype on RedHat Linux.
include/includes.h: Fix crypt prototype on RedHat Linux. smbd/fileio.c: Fix mmap bug found by WinCE client. smbd/ipc.c: Fix WinCE wierdness with pipes being opened as \server\pipe\lanman smbd/password.c: Fix encrypted null passwords. Jeremy. (This used to be commit 475992730c0ecbf31c09b3518df2f0354cec61da)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 1cfeb1a3b4..dc036c6238 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -123,6 +123,14 @@ if test x"$samba_cv_have_setresuid_decl" = x"yes"; then
AC_DEFINE(HAVE_SETRESUID_DECL)
fi
+# stupid glibc has the functions but no declaration. grrrr.
+AC_CACHE_CHECK([for crypt declaration],samba_cv_have_crypt_decl,[
+ AC_TRY_COMPILE([#include <unistd.h>],[int i = crypt],
+ samba_cv_have_crypt_decl=yes,samba_cv_have_crypt_decl=no)])
+if test x"$samba_cv_have_crypt_decl" = x"yes"; then
+ AC_DEFINE(HAVE_CRYPT_DECL)
+fi
+
# and glibc has setresuid under linux but the function does
# nothing until kernel 2.1.44! very dumb.
AC_CACHE_CHECK([for real setresuid],samba_cv_have_setresuid,[