summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJim McDonough <jmcd@samba.org>2001-10-23 17:12:30 +0000
committerJim McDonough <jmcd@samba.org>2001-10-23 17:12:30 +0000
commit053f21feda024bbe6dd41de481794966008b6b0e (patch)
tree3d45a5a0258044675f1f37c84ca38552f43c3265 /source3/configure.in
parentb955d94d5cd7ca575d5fabd5d85c7c523d2a5e58 (diff)
downloadsamba-053f21feda024bbe6dd41de481794966008b6b0e.tar.gz
samba-053f21feda024bbe6dd41de481794966008b6b0e.tar.bz2
samba-053f21feda024bbe6dd41de481794966008b6b0e.zip
Fix popt library checking
(This used to be commit 2cd33e88eb5ed88da90ddfd50a1ec96a2053479a)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 1de15c4333..134b7ec6af 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2491,8 +2491,9 @@ AC_ARG_WITH(included-popt,
;;
esac ],
)
-if test x"$INCLUDED_POPT" = x"no"; then
- AC_CHECK_LIB(popt, poptGetContext, ,INCLUDED_POPT=yes)
+if test x"$INCLUDED_POPT" != x"yes"; then
+ AC_CHECK_LIB(popt, poptGetContext,
+ INCLUDED_POPT=no, INCLUDED_POPT=yes)
fi
if test x"$INCLUDED_POPT" = x"yes"; then