summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>1998-09-05 13:21:57 +0000
committerAndrew Tridgell <tridge@samba.org>1998-09-05 13:21:57 +0000
commit0cb85e04a974daf4442a7561931ff1be566a8410 (patch)
treea24dcd47d6f5f2f3dd4c6971543cddee2ca01720 /source3/configure.in
parent012e575e1336fbba70174d32c26ecab9ce5523ce (diff)
downloadsamba-0cb85e04a974daf4442a7561931ff1be566a8410.tar.gz
samba-0cb85e04a974daf4442a7561931ff1be566a8410.tar.bz2
samba-0cb85e04a974daf4442a7561931ff1be566a8410.zip
some people are foolishly running ./configure from other than the
source directory! This adds a new "trivial" test that makes sure that the autoconf tests are working. It aborts the configure run if not. (This used to be commit ead0338ad27f29f1abbbe9f6302d6bf633bf98b2)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4ad5a05402..98a5ad1498 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -256,6 +256,12 @@ AC_TRY_COMPILE([#include <sys/types.h>
echo yes;AC_DEFINE(HAVE_UTIMBUF),
echo no)
+
+echo $ac_n "checking for test routines ... $ac_c"
+AC_TRY_RUN([#include "tests/trivial.c"],
+ echo yes;,
+ echo ERROR - cant find test code. Aborting config; exit 1)
+
echo $ac_n "checking for ftruncate extend ... $ac_c"
AC_TRY_RUN([#include "tests/ftruncate.c"],
echo yes;AC_DEFINE(HAVE_FTRUNCATE_EXTEND),