summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2000-06-14 07:10:15 +0000
committerAndrew Tridgell <tridge@samba.org>2000-06-14 07:10:15 +0000
commit1896c721fbd01b6d1f95b05350010c17fccbf612 (patch)
tree7cc63d4812f646f2758f26c9408c917f549c5ef2 /source3/configure.in
parent31e83abd3d275014c2841e66f5d46ef0997e5737 (diff)
downloadsamba-1896c721fbd01b6d1f95b05350010c17fccbf612.tar.gz
samba-1896c721fbd01b6d1f95b05350010c17fccbf612.tar.bz2
samba-1896c721fbd01b6d1f95b05350010c17fccbf612.zip
fixed autoconf test for kernel change notify support
(This used to be commit 92d0382c9e1d6d31e6047ca3d78523a3204d36f8)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index c28beb2429..4b8b03a72b 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -720,6 +720,27 @@ if test x"$samba_cv_HAVE_KERNEL_OPLOCKS_LINUX" = x"yes"; then
AC_DEFINE(HAVE_KERNEL_OPLOCKS_LINUX)
fi
+AC_CACHE_CHECK([for kernel change notify support],samba_cv_HAVE_KERNEL_CHANGE_NOTIFY,[
+AC_TRY_RUN([
+#include <sys/types.h>
+#include <fcntl.h>
+#include <signal.h>
+#ifndef F_NOTIFY
+#define F_NOTIFY 1026
+#endif
+main() {
+ signal(SIGIO, SIG_IGN);
+ exit(fcntl(open("/tmp", O_RDONLY), F_NOTIFY, 0xF) != 0);
+}
+],
+samba_cv_HAVE_KERNEL_CHANGE_NOTIFY=yes,samba_cv_HAVE_KERNEL_CHANGE_NOTIFY=no,samba_cv_HAVE_KERNEL_CHANGE_NOTIFY=cross)])
+if test x"$samba_cv_HAVE_KERNEL_CHANGE_NOTIFY" = x"yes"; then
+ AC_DEFINE(HAVE_KERNEL_CHANGE_NOTIFY)
+fi
+
+
+
+
AC_CACHE_CHECK([for IRIX kernel oplock type definitions],samba_cv_HAVE_KERNEL_OPLOCKS_IRIX,[
AC_TRY_COMPILE([#include <sys/types.h>
#include <fcntl.h>],