summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2005-05-02 10:12:36 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:56:45 -0500
commit2d1e1f7e2e9a1bc30c12610462757fd422e7ffb4 (patch)
tree88a05bd57c88610de5a4f0e5cfcccc06dda98417 /source3/configure.in
parenta7145e26c99c43a39b24bbf16587b2ea1cd1ef9c (diff)
downloadsamba-2d1e1f7e2e9a1bc30c12610462757fd422e7ffb4.tar.gz
samba-2d1e1f7e2e9a1bc30c12610462757fd422e7ffb4.tar.bz2
samba-2d1e1f7e2e9a1bc30c12610462757fd422e7ffb4.zip
r6570: Add socket_wrapper library to 3.0. Can be enabled by passing
--enable-socket-wrapper to configure (This used to be commit 9c6cdd23ead427a4cb20177dad1c87da9594a4fe)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index fb73c8a58e..d84c543597 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -237,6 +237,14 @@ AC_ARG_ENABLE(debug,
CFLAGS="${CFLAGS} -g"
fi])
+AC_SUBST(SOCKWRAP)
+AC_ARG_ENABLE(socket-wrapper,
+[ --enable-socket-wrapper Turn on socket wrapper library (default=no)],
+ [if eval "test x$enable_socket_wrapper = xyes"; then
+ AC_DEFINE(SOCKET_WRAPPER,1,[Use socket wrapper library])
+ SOCKWRAP="\$(SOCKET_WRAPPER_OBJ)"
+ fi])
+
# compile with optimization and without debugging by default, but
# allow people to set their own preference.
# do this here since AC_CACHE_CHECK apparently sets the CFLAGS to "-g -O2"