summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2007-03-08 18:05:55 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:18:29 -0500
commit30b9b9acae1a0bcea100e7fd9d2cdf29bf25148f (patch)
tree48149299ee4539efa1e0e8b32df1de18566595e1 /source3/configure.in
parent70d5f417ab7abf1ac41db72e2cbaee5ccda51a2e (diff)
downloadsamba-30b9b9acae1a0bcea100e7fd9d2cdf29bf25148f.tar.gz
samba-30b9b9acae1a0bcea100e7fd9d2cdf29bf25148f.tar.bz2
samba-30b9b9acae1a0bcea100e7fd9d2cdf29bf25148f.zip
r21763: Add support for the UNIX_INFO2 infolevel.
(This used to be commit 262e4e1fd8398934780db354fcc5316368032d7b)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 38449dae33..3e407cf5dc 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2976,6 +2976,23 @@ if test x"$samba_cv_HAVE_STAT_ST_BLKSIZE" = x"yes"; then
AC_DEFINE(HAVE_STAT_ST_BLKSIZE,1,[Whether the stat struct has a st_blksize property])
fi
+AC_CACHE_CHECK([for st_flags in struct stat],
+ samba_cv_HAVE_STAT_ST_FLAGS,
+ [
+ AC_TRY_COMPILE([#include <sys/types.h>
+#include <sys/stat.h>
+#include <unistd.h>],
+ [struct stat st; st.st_flags = 0;],
+ samba_cv_HAVE_STAT_ST_FLAGS=yes,
+ samba_cv_HAVE_STAT_ST_FLAGS=no,
+ samba_cv_HAVE_STAT_ST_FLAGS=cross)
+ ])
+
+if test x"$samba_cv_HAVE_STAT_ST_FLAGS" = x"yes"; then
+ AC_DEFINE(HAVE_STAT_ST_FLAGS, 1,
+ [Whether the stat struct has a st_flags member])
+fi
+
case "$host_os" in
*linux*)
AC_CACHE_CHECK([for broken RedHat 7.2 system header files],samba_cv_BROKEN_REDHAT_7_SYSTEM_HEADERS,[