summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vl@samba.org>2008-12-10 18:17:59 +0100
committerVolker Lendecke <vl@samba.org>2008-12-10 18:30:28 +0100
commit3c93c96fd0fe362c35fe8127058f94868abc9342 (patch)
treed97856d6e612b1ff680d58d46bb7d58aa2430168 /source3/configure.in
parentb37684ffcec4ba0beada55d37bcaf4f5e79bcd58 (diff)
downloadsamba-3c93c96fd0fe362c35fe8127058f94868abc9342.tar.gz
samba-3c93c96fd0fe362c35fe8127058f94868abc9342.tar.bz2
samba-3c93c96fd0fe362c35fe8127058f94868abc9342.zip
Also search for -lgpfs which is available as GPL in GPFS PTF8
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 40e78e89d9..b90b1b3f60 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1052,6 +1052,20 @@ if test x"$samba_cv_HAVE_GPFS" = x"yes"; then
fi
LIBS="$save_LIBS"
+printf "%s" "checking for GPFS libs (with 3.2.1 PTF8 available as GPL)... "
+save_LIBS="$LIBS"
+LIBS="$LIBS -lgpfs"
+AC_TRY_LINK([#include <gpfs.h>],
+ [gpfs_set_share(0,GPFS_SHARE_READ,GPFS_DENY_NONE)],
+ samba_cv_HAVE_GPFS=yes,
+ samba_cv_HAVE_GPFS=no)
+echo $samba_cv_HAVE_GPFS
+if test x"$samba_cv_HAVE_GPFS" = x"yes"; then
+ AC_DEFINE(HAVE_GPFS,1,[Whether GPFS GPL libs are available])
+ default_shared_modules="$default_shared_modules vfs_gpfs"
+fi
+LIBS="$save_LIBS"
+
#############################################
# check if building on Isilon OneFS
printf "%s" "checking for Isilon OneFS... "