summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2005-09-14 23:58:14 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:03:38 -0500
commit418e92d06da0638d92c48ffd310a409c89e2fa48 (patch)
tree26568c796d59b73daadaa19101c279da06f7a1b0 /source3/configure.in
parenta9b96c6b3d2fa111c2210b57fa816fcbc1946fc5 (diff)
downloadsamba-418e92d06da0638d92c48ffd310a409c89e2fa48.tar.gz
samba-418e92d06da0638d92c48ffd310a409c89e2fa48.tar.bz2
samba-418e92d06da0638d92c48ffd310a409c89e2fa48.zip
r10234: Add new auth module "auth_script" to allow valid users to
be provisioned on demand - calls script with domain, username, challenge and LM and NT responses - passing the info through a pipe. Jeremy. (This used to be commit 67be4ee41cd244bcc0445cac7c9e1e2d40e93c9b)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index c0afe0de1d..dbb27d1a60 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -460,7 +460,7 @@ dnl These have to be built static:
default_static_modules="pdb_smbpasswd pdb_tdbsam rpc_lsa rpc_samr rpc_reg rpc_lsa_ds rpc_wks rpc_svcctl rpc_net rpc_dfs rpc_srv rpc_spoolss rpc_eventlog auth_rhosts auth_sam auth_unix auth_winbind auth_server auth_domain auth_builtin printerdb_file"
dnl These are preferably build shared, and static if dlopen() is not available
-default_shared_modules="vfs_recycle vfs_audit vfs_extd_audit vfs_full_audit vfs_netatalk vfs_fake_perms vfs_default_quota vfs_readonly vfs_cap vfs_expand_msdfs vfs_shadow_copy charset_CP850 charset_CP437"
+default_shared_modules="vfs_recycle vfs_audit vfs_extd_audit vfs_full_audit vfs_netatalk vfs_fake_perms vfs_default_quota vfs_readonly vfs_cap vfs_expand_msdfs vfs_shadow_copy charset_CP850 charset_CP437 auth_script"
if test "x$developer" = xyes; then
default_static_modules="$default_static_modules rpc_echo"
@@ -4973,6 +4973,7 @@ SMB_MODULE(auth_winbind, \$(AUTH_WINBIND_OBJ), "bin/winbind.$SHLIBEXT", AUTH)
SMB_MODULE(auth_server, \$(AUTH_SERVER_OBJ), "bin/smbserver.$SHLIBEXT", AUTH)
SMB_MODULE(auth_domain, \$(AUTH_DOMAIN_OBJ), "bin/domain.$SHLIBEXT", AUTH)
SMB_MODULE(auth_builtin, \$(AUTH_BUILTIN_OBJ), "bin/builtin.$SHLIBEXT", AUTH)
+SMB_MODULE(auth_script, \$(AUTH_SCRIPT_OBJ), "bin/script.$SHLIBEXT", AUTH)
SMB_SUBSYSTEM(AUTH,auth/auth.o)
SMB_MODULE(vfs_recycle, \$(VFS_RECYCLE_OBJ), "bin/recycle.$SHLIBEXT", VFS)