summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGünther Deschner <gd@samba.org>2005-01-24 16:30:46 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:55:09 -0500
commit446a2107e639e4a4e6b94e1c06e791a1012eedd2 (patch)
tree4c3bf53a3156819a4385364cad8ad01fcc96a925 /source3/configure.in
parentfcfc94a66ac66af1f12cb5924df31e936bca3dc9 (diff)
downloadsamba-446a2107e639e4a4e6b94e1c06e791a1012eedd2.tar.gz
samba-446a2107e639e4a4e6b94e1c06e791a1012eedd2.tar.bz2
samba-446a2107e639e4a4e6b94e1c06e791a1012eedd2.zip
r4963: It is actually a very bad idea to use KRB5_CONFIG in the
configure-checks (At least Heimdal uses KRB5_CONFIG for locating it's configuration-file (usually /etc/krb5.conf)). Renaming it to KRB5CONFIG prevents configure-checks that use heimdal-libs from segfaulting while the lib reads the krb5-config binary as a configuration file... Vendors that used the KRB5_CONFIG-variable to let configure find a custom krb5-config binary have to use KRB5CONFIG now. Guenther (This used to be commit 95edb3c67f330afd8dbb8268f3f8ecaf1732c238)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 330eed79f1..0dcfd9ab1e 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2655,7 +2655,7 @@ if test x"$with_ads_support" != x"no"; then
KRB5_LDFLAGS="-L$withval/lib"
FOUND_KRB5=yes
if test -x "$withval/bin/krb5-config"; then
- KRB5_CONFIG=$withval/bin/krb5-config
+ KRB5CONFIG=$withval/bin/krb5-config
fi
;;
esac ],
@@ -2665,17 +2665,17 @@ if test x"$with_ads_support" != x"no"; then
#################################################
# check for krb5-config from recent MIT and Heimdal kerberos 5
- AC_PATH_PROG(KRB5_CONFIG, krb5-config)
+ AC_PATH_PROG(KRB5CONFIG, krb5-config)
AC_MSG_CHECKING(for working krb5-config)
- if test -x "$KRB5_CONFIG"; then
+ if test -x "$KRB5CONFIG"; then
ac_save_CFLAGS=$CFLAGS
CFLAGS="";export CFLAGS
ac_save_LDFLAGS=$LDFLAGS
LDFLAGS="";export LDFLAGS
- KRB5_LIBS="`$KRB5_CONFIG --libs gssapi`"
- KRB5_LDFLAGS="`$KRB5_CONFIG --libs gssapi | sed s/-lgss.*//`"
- KRB5_CFLAGS="`$KRB5_CONFIG --cflags | sed s/@INCLUDE_des@//`"
- KRB5_CPPFLAGS="`$KRB5_CONFIG --cflags | sed s/@INCLUDE_des@//`"
+ KRB5_LIBS="`$KRB5CONFIG --libs gssapi`"
+ KRB5_LDFLAGS="`$KRB5CONFIG --libs gssapi | sed s/-lgss.*//`"
+ KRB5_CFLAGS="`$KRB5CONFIG --cflags | sed s/@INCLUDE_des@//`"
+ KRB5_CPPFLAGS="`$KRB5CONFIG --cflags | sed s/@INCLUDE_des@//`"
CFLAGS=$ac_save_CFLAGS;export CFLAGS
LDFLAGS=$ac_save_LDFLAGS;export LDFLAGS
FOUND_KRB5=yes