summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vlendec@samba.org>2006-09-14 11:58:22 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:51:45 -0500
commit5077d280811a084d955b9d39bcb0d86faa80f680 (patch)
tree3700fe6266ba30a15a89a854b1552537cb776eb4 /source3/configure.in
parent2ad8c705b238e8ebb87fed51b962b4e165c1202f (diff)
downloadsamba-5077d280811a084d955b9d39bcb0d86faa80f680.tar.gz
samba-5077d280811a084d955b9d39bcb0d86faa80f680.tar.bz2
samba-5077d280811a084d955b9d39bcb0d86faa80f680.zip
r18519: Copy over the Samba4 code to figure out options for the named initializers.
Volker (This used to be commit 1786c28cc353e2ba70abe2750b9ef804cec84bf0)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 5bea72e224..1c5fa609d9 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -540,6 +540,10 @@ if test x"$samba_cv_volatile" = x"yes"; then
AC_DEFINE(HAVE_VOLATILE, 1, [Whether the C compiler understands volatile])
fi
+dnl Figure out the flags to support named structure initializers
+
+LIBREPLACE_C99_STRUCT_INIT([],[AC_MSG_WARN([c99 structure initializer are not supported])])
+
UNAME_S=`(uname -s) 2>/dev/null` || UNAME_S="unknown"
AC_MSG_CHECKING(uname -s)
AC_MSG_RESULT(${UNAME_S})