summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorRichard Sharpe <sharpe@samba.org>2003-11-13 17:04:59 +0000
committerRichard Sharpe <sharpe@samba.org>2003-11-13 17:04:59 +0000
commit618d7dd0c77cc125611e97d60d6759fb0a0ccb5c (patch)
tree0aa391117fd681c0448cb3b3fc88bf58d38dca51 /source3/configure.in
parentbd4e882b0b5e6ae9d64c784b16a3b7fffb6c5e50 (diff)
downloadsamba-618d7dd0c77cc125611e97d60d6759fb0a0ccb5c.tar.gz
samba-618d7dd0c77cc125611e97d60d6759fb0a0ccb5c.tar.bz2
samba-618d7dd0c77cc125611e97d60d6759fb0a0ccb5c.zip
Keep configure.in in sync with SAMBA-3.0.0
(This used to be commit 664cc4f46cf1be08c704a9d163ee33c8629ad065)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 269fdf97ed..2c1880f3b2 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1617,7 +1617,7 @@ dnl Try to find iconv(3)
LDFLAGS=$save_LDFLAG
LIB_ADD_DIR(LDFLAGS, "$i/lib")
CFLAGS_ADD_DIR(CPPFLAGS, "$i/include")
- LIBS="$save_LIBS"
+ LIBS="$save_LIBS"
ICONV_LOCATION=$i
export LDFLAGS LIBS CPPFLAGS
dnl Now, check for a working iconv ... we want to do it here because
@@ -1629,6 +1629,9 @@ dnl there might be a working iconv further down the list of LOOK_DIRS
if test x"$ICONV_PATH_SPEC" = "xyes" ; then
LIBS="$LIBS -L$ICONV_LOCATION/lib"
fi
+ if test x"$jm_cv_lib_iconv" != x; then
+ LIBS="$LIBS -l$jm_cv_lib_iconv"
+ fi
dnl AC_CACHE_CHECK([for working iconv],samba_cv_HAVE_NATIVE_ICONV,[
default_dos_charset=no
default_display_charset=no
@@ -1683,6 +1686,13 @@ dnl ])
if test x"$samba_cv_HAVE_NATIVE_ICONV" = x"yes"; then
CPPFLAGS=$save_CPPFLAGS
CFLAGS_ADD_DIR(CPPFLAGS, "$i/include")
+ LIBS=$save_LIBS
+ if test x"$jm_cv_lib_iconv" != x; then
+ LIBS="$LIBS -l$jm_cv_lib_iconv"
+ fi
+ dnl Add the flags we need to CPPFLAGS and LDFLAGS
+ CFLAGS_ADD_DIR(CPPFLAGS, "$i/include")
+ LIB_ADD_DIR(LDFLAGS, "$i/lib")
export CPPFLAGS
AC_DEFINE(HAVE_NATIVE_ICONV,1,[Whether to use native iconv])
AC_DEFINE_UNQUOTED(DEFAULT_DOS_CHARSET,$default_dos_charset,[Default dos charset name])