summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2010-05-06 12:00:01 +0200
committerJelmer Vernooij <jelmer@samba.org>2010-05-07 18:34:00 +0200
commit674a78d60a7dbc4d2af1b229a6b3b2a96c2517f3 (patch)
treeed769f7f2ab1dc8eb108437450188eace98e9f77 /source3/configure.in
parentc18d58b854836fc8df56883f7197d6fce0d70c1d (diff)
downloadsamba-674a78d60a7dbc4d2af1b229a6b3b2a96c2517f3.tar.gz
samba-674a78d60a7dbc4d2af1b229a6b3b2a96c2517f3.tar.bz2
samba-674a78d60a7dbc4d2af1b229a6b3b2a96c2517f3.zip
Revert "Revert "s3-build: Remove --enable-merged support.""
This reverts commit 8f8e7c788a12d1e0bda9183ed765cc1048e105f7.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in51
1 files changed, 3 insertions, 48 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 050c16a024..c42139604b 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -195,17 +195,15 @@ AC_ARG_WITH(profiling-data,
)
dnl Checks for programs.
-merged_build_possible=yes
-
AC_PROG_INSTALL
AC_PROG_AWK
# Check for GNU make
m4_include(../m4/check_make.m4)
-AC_SAMBA_GNU_MAKE([true], [merged_build_possible=no])
+AC_SAMBA_GNU_MAKE([true], [true])
# Check for perl
m4_include(../m4/check_perl.m4)
-AC_SAMBA_PERL([true], [merged_build_possible=no])
+AC_SAMBA_PERL([true], [true])
AC_CHECK_TOOL(AR, ar)
@@ -1836,7 +1834,6 @@ if test x"$BLDSHARED" != x"true"; then
SHLD="shared-libraries-disabled"
PICFLAG="${PIE_CFLAGS}"
SHLIBEXT="shared_libraries_disabled"
- merged_build_possible=no
fi
AC_MSG_CHECKING([used PICFLAG])
@@ -4238,10 +4235,6 @@ if test x"$with_ads_support" != x"no"; then
LIBS="$ac_save_LIBS"
fi
-if test x"$use_ads" != xyes; then
- merged_build_possible=no
-fi
-
AC_CHECK_LIB_EXT(nscd, NSCD_LIBS, nscd_flush_cache)
PASSDB_LIBS="$PASSDB_LIBS $NSCD_LIBS"
@@ -6630,39 +6623,8 @@ MSG
fi
-AC_ARG_ENABLE(merged-build,
-[AS_HELP_STRING([--enable-merged-build], [Build Samba 4 as well])],
-[ enable_merged_build=$enableval ], [ enable_merged_build=auto ])
-
-if test x"$enable_merged_build" = x"yes" -a \
- x"$merged_build_possible" = x"no" ; then
- AC_MSG_ERROR(Merged build required but not possible)
-fi
-
m4_include(../lib/zlib/zlib.m4)
-if test x$enable_merged_build = xauto; then
- # Check for python
- m4_include(../m4/check_python.m4)
- AC_SAMBA_PYTHON_DEVEL([true], [merged_build_possible=no])
-
- AC_MSG_CHECKING([whether it would be possible to do a merged build])
- AC_MSG_RESULT([$merged_build_possible])
-
- # Enable merged build automatically if possible, when in developer mode
- if test "x$developer" = xyes; then
- enable_merged_build=$merged_build_possible
- fi
-fi
-
-if test x$enable_merged_build = xyes; then
- MERGED_BUILD=1
- saved_USESHARED="$USESHARED"
- USESHARED="false"
- m4_include(samba4.m4)
- USESHARED="$saved_USESHARED"
-fi
-
AC_SUBST(ZLIB_LIBS)
AC_SUBST(ZLIB_OBJS)
AC_ZLIB([ZLIB_OBJS=""], [
@@ -6734,14 +6696,7 @@ SMBD_LIBS="$samba_dmapi_libs"
AC_SUBST(SMBD_LIBS)
CFLAGS="${CFLAGS} \$(FLAGS)"
-
-if test x$MERGED_BUILD != x1; then
- CFLAGS="${CFLAGS} -D_SAMBA_BUILD_=3"
-else
- if test x"$BLDSHARED" = x"true" ; then
- LDFLAGS="$LDFLAGS -L./bin"
- fi
-fi
+CFLAGS="${CFLAGS} -D_SAMBA_BUILD_=3"
AC_SUBST(MAKEFILE)
if test x$samba_cv_gnu_make = xyes; then