summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2005-06-06 13:30:45 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:57:06 -0500
commit74a98c60724c0f993ee3a5efbc46c1ba57b9dd20 (patch)
treeb6633fbdfa49e26344fccf4642ed6f398552e561 /source3/configure.in
parent06ae1e805e45fa381739a64ef79fa99b25fa025c (diff)
downloadsamba-74a98c60724c0f993ee3a5efbc46c1ba57b9dd20.tar.gz
samba-74a98c60724c0f993ee3a5efbc46c1ba57b9dd20.tar.bz2
samba-74a98c60724c0f993ee3a5efbc46c1ba57b9dd20.zip
r7335: patch from Joerg Sonnenberger <joerg@britannica.bec.de> to fix dragonfly detection
(This used to be commit d80ae98d9e3f872c8064ce8316c76bd6de50a848)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 7de65981eb..14fd135093 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -544,7 +544,7 @@ case "$host_os" in
*irix*)
AC_DEFINE(SYSV, 1, [Whether to enable System V compatibility])
;;
- *freebsd*|*DragonFly*)
+ *freebsd*|*dragonfly*)
AC_DEFINE(FREEBSD, 1, [Whether the host os is FreeBSD])
;;
#
@@ -1180,7 +1180,7 @@ AC_CHECK_FUNCS(attr_get attr_list attr_set attr_remove)
AC_CHECK_FUNCS(attr_getf attr_listf attr_setf attr_removef)
# Check if we have extattr
case "$host_os" in
- *freebsd4* | *DragonFly* )
+ *freebsd4* | *dragonfly* )
AC_DEFINE(BROKEN_EXTATTR, 1, [Does extattr API work])
;;
*)
@@ -1251,7 +1251,7 @@ if test "$enable_shared" = "yes"; then
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
AC_DEFINE(BROKEN_GETGRNAM,1,[Does getgrnam work correctly])
;;
- *netbsd* | *freebsd* | *DragonFly* )
+ *netbsd* | *freebsd* | *dragonfly* )
BLDSHARED="true"
LDSHFLAGS="-shared"
DYNEXP="-Wl,--export-dynamic"
@@ -4116,7 +4116,7 @@ samba_cv_HAVE_BROKEN_LINUX_SENDFILE=yes,samba_cv_HAVE_BROKEN_LINUX_SENDFILE=no)]
fi
;;
- *freebsd* | *DragonFly* )
+ *freebsd* | *dragonfly* )
AC_CACHE_CHECK([for freebsd sendfile support],samba_cv_HAVE_SENDFILE,[
AC_TRY_LINK([\
#include <sys/types.h>