summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAlexander Bokovoy <ab@samba.org>2003-08-26 19:48:16 +0000
committerAlexander Bokovoy <ab@samba.org>2003-08-26 19:48:16 +0000
commit7e27147422e78125c2bb5b8115bd9084a657e084 (patch)
tree5653755bc833ca1376ce0539dd78a448c45c5505 /source3/configure.in
parent5e6c6d766f5782dd1f91bf249f5f8ea7878977a6 (diff)
downloadsamba-7e27147422e78125c2bb5b8115bd9084a657e084.tar.gz
samba-7e27147422e78125c2bb5b8115bd9084a657e084.tar.bz2
samba-7e27147422e78125c2bb5b8115bd9084a657e084.zip
Fix for #150.
We now fallback to Samba-provided CP850 charset module if CP850 or IBM850 does not exist on target system at runtime. 1. Introduce CP850 charset module based on charmaps table from GNU libc 2.2.5 2. Make CP850 charset module shared and build it by default Should fix Solaris run-time (This used to be commit e855dc8c9115fa11d315eb34d57722ff612daa11)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 241c6ec76f..e23dc77638 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -288,7 +288,7 @@ dnl These have to be built static:
default_static_modules="pdb_smbpasswd pdb_tdbsam rpc_lsa rpc_samr rpc_reg rpc_lsa_ds rpc_wks rpc_net rpc_dfs rpc_srv rpc_spoolss auth_rhosts auth_sam auth_unix auth_winbind auth_server auth_domain auth_builtin"
dnl These are preferably build shared, and static if dlopen() is not available
-default_shared_modules="vfs_recycle vfs_audit vfs_extd_audit vfs_netatalk vfs_fake_perms vfs_default_quota vfs_readonly"
+default_shared_modules="vfs_recycle vfs_audit vfs_extd_audit vfs_netatalk vfs_fake_perms vfs_default_quota vfs_readonly charset_CP850"
if test "x$developer" = xyes; then
default_static_modules="$default_static_modules rpc_echo"
@@ -4004,6 +4004,7 @@ SMB_MODULE(idmap_tdb, sam/idmap_tdb.o, "bin/idmap_tdb.$SHLIBEXT", IDMAP)
SMB_SUBSYSTEM(IDMAP,sam/idmap.c)
SMB_MODULE(charset_weird, modules/weird.o, "bin/weird.$SHLIBEXT", CHARSET)
+SMB_MODULE(charset_CP850, modules/CP850.o, "bin/CP850.$SHLIBEXT", CHARSET)
SMB_SUBSYSTEM(CHARSET,lib/iconv.c)
SMB_MODULE(auth_rhosts, \$(AUTH_RHOSTS_OBJ), "bin/rhosts.$SHLIBEXT", AUTH)