summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2002-05-13 00:06:35 +0000
committerTim Potter <tpot@samba.org>2002-05-13 00:06:35 +0000
commit7f807117d782b81e83a9181d337275a36eeeb301 (patch)
treedccf94b4ef7f899872ab7a48ae00d81be0dd3412 /source3/configure.in
parentee2306d88156af9b03c135889672e6ce3ec49636 (diff)
downloadsamba-7f807117d782b81e83a9181d337275a36eeeb301.tar.gz
samba-7f807117d782b81e83a9181d337275a36eeeb301.tar.bz2
samba-7f807117d782b81e83a9181d337275a36eeeb301.zip
Merge of Solaris winbindd fixes.
(This used to be commit 4bbc584e6ce9cbc32bae715fd3fec0d89f2e271f)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index bbfdc2e382..9806594449 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2665,6 +2665,33 @@ AC_SUBST(WINBIND_PAM_TARGETS)
AC_SUBST(WINBIND_NSS_EXTRA_OBJS)
AC_SUBST(WINBIND_NSS_EXTRA_LIBS)
+# Solaris has some extra fields in struct passwd that need to be
+# initialised otherwise nscd crashes. Unfortunately autoconf < 2.50
+# doesn't have the AC_CHECK_MEMBER macro which would be handy for checking
+# this.
+
+#AC_CHECK_MEMBER(struct passwd.pw_comment,
+# AC_DEFINE(HAVE_PASSWD_PW_COMMENT, 1, [Defined if struct passwd has pw_comment field]),
+# [#include <pwd.h>])
+
+AC_CACHE_CHECK([whether struct passwd has pw_comment],samba_cv_passwd_pw_comment, [
+ AC_TRY_COMPILE([#include <pwd.h>],[struct passwd p; p.pw_comment;],
+ samba_cv_passwd_pw_comment=yes,samba_cv_passwd_pw_comment=no)])
+if test x"$samba_cv_passwd_pw_comment" = x"yes"; then
+ AC_DEFINE(HAVE_PASSWD_PW_COMMENT)
+fi
+
+#AC_CHECK_MEMBER(struct passwd.pw_age,
+# AC_DEFINE(HAVE_PASSWD_PW_AGE, 1, [Defined if struct passwd has pw_age field]),
+# [#include <pwd.h>])
+
+AC_CACHE_CHECK([whether struct passwd has pw_age],samba_cv_passwd_pw_age, [
+ AC_TRY_COMPILE([#include <pwd.h>],[struct passwd p; p.pw_age;],
+ samba_cv_passwd_pw_age=yes,samba_cv_passwd_pw_age=no)])
+if test x"$samba_cv_passwd_pw_age" = x"yes"; then
+ AC_DEFINE(HAVE_PASSWD_PW_AGE)
+fi
+
#################################################
# Check to see if we should use the included popt