summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2007-04-22 03:17:31 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:19:34 -0500
commit821bf2bd7278da4e71fcdcfc03348a712cd0fc90 (patch)
treec1478a5a9dea7e473b0c00ec7b53543be963b045 /source3/configure.in
parentd27d6e822ecd90ebddf59121c2051b693b6b0f90 (diff)
downloadsamba-821bf2bd7278da4e71fcdcfc03348a712cd0fc90.tar.gz
samba-821bf2bd7278da4e71fcdcfc03348a712cd0fc90.tar.bz2
samba-821bf2bd7278da4e71fcdcfc03348a712cd0fc90.zip
r22441: Add automatic dependency tracking. The dependency generation is
toolchain independent, but since there's no portable method for doing makefile includes, we can actually use the dependencies with GNU make. It's easy to add this for other makes, but I don't have any to test. This also moves as much m4 as possible into the m4 directory where no-one has to look at it. AFAICT, there's no way to hide depcomp in there too, which is unfortunate. (This used to be commit aa14900f8291a017aa7fab2bbb9a6c79b12889b2)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in24
1 files changed, 23 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index bc5d5184a4..9980d18f43 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -573,7 +573,29 @@ if test x"$SMB_BUILD_CC_NEGATIVE_ENUM_VALUES" != x"yes"; then
PIDL_ARGS="$PIDL_ARGS --uint-enums"
fi
-dnl Figure out the flags to support named structure initializers
+############################################
+# Check whether we can do automatic dependency tracking
+
+m4_include(m4/substnot.m4)
+m4_include(m4/cond.m4)
+m4_include(m4/make.m4)
+m4_include(m4/depout.m4)
+m4_include(m4/lead-dot.m4)
+m4_include(m4/check_gnu_make.m4)
+m4_include(m4/depend.m4)
+
+# Using the dependency files requires GNU make until someone adds support
+# for Makefile includes for other make implementations.
+CHECK_GNU_MAKE()
+if test "x$_cv_gnu_make_command" != "x" ; then
+ AC_SUBST(MAKE, $_cv_gnu_make_command)
+fi
+
+AM_DEP_TRACK()
+_AM_DEPENDENCIES(CC)
+
+############################################
+# Figure out the flags to support named structure initializers
LIBREPLACE_C99_STRUCT_INIT([],[AC_MSG_ERROR([c99 structure initializer are not supported])])