summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2001-05-16 02:32:34 +0000
committerTim Potter <tpot@samba.org>2001-05-16 02:32:34 +0000
commit84913375ccd0af818f5b78c7ab30f32a9d9b0478 (patch)
treed8992d79c1cb36131e601f077c3cd72b1718c00a /source3/configure.in
parent5df33ed012c21a3478ccff7ee6398940bafa30e3 (diff)
downloadsamba-84913375ccd0af818f5b78c7ab30f32a9d9b0478.tar.gz
samba-84913375ccd0af818f5b78c7ab30f32a9d9b0478.tar.bz2
samba-84913375ccd0af818f5b78c7ab30f32a9d9b0478.zip
Added winbind programs to build for supported systems (i.e linux and
solaris) so the autobuilder can have a crack at it. Cosmetic fix for large file support ./configure output. (This used to be commit ded776af285baa65af151710fe7440b6c52fc409)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in23
1 files changed, 20 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 82b30b562a..5c88496509 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2110,10 +2110,7 @@ __COMPILE_ERROR_
[int i],
samba_cv_HAVE_EXPLICIT_LARGEFILE_SUPPORT=yes,samba_cv_HAVE_EXPLICIT_LARGEFILE_SUPPORT=no)
if test x"$samba_cv_HAVE_EXPLICIT_LARGEFILE_SUPPORT" = x"yes"; then
- AC_MSG_RESULT(yes)
AC_DEFINE(HAVE_EXPLICIT_LARGEFILE_SUPPORT)
-else
- AC_MSG_RESULT(no)
fi
AC_MSG_RESULT([$samba_cv_HAVE_EXPLICIT_LARGEFILE_SUPPORT])
@@ -2206,6 +2203,26 @@ samba_cv_HAVE_XFS_ACLS=yes,samba_cv_XFS_POSIX_ACLS=no)])
AC_DEFINE(HAVE_NO_ACLS)
AC_MSG_RESULT(no)
)
+
+#################################################
+# check whether winbind is supported on this platform
+
+AC_MSG_CHECKING(whether to compile winbind)
+case "$host_os" in
+ *linux*|*solaris*)
+ AC_MSG_RESULT(yes)
+ WINBIND_TARGETS="$WINBIND_TARGETS \$(WINBIND_PROGS)"
+ ;;
+ *)
+ AC_MSG_RESULT(unsupported for $host_os)
+ ;;
+esac
+
+AC_SUBST(WINBIND_TARGETS)
+
+#################################################
+# final configure stuff
+
echo "checking configure summary"
AC_TRY_RUN([#include "${srcdir-.}/tests/summary.c"],
echo "configure OK";,