summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2001-03-31 19:06:45 +0000
committerJeremy Allison <jra@samba.org>2001-03-31 19:06:45 +0000
commit92368833faf51fd56e95a2d646eaae1d697f8e81 (patch)
tree5e3fb828c83e149b7854a592ad173e0cf96462cd /source3/configure.in
parent578a9fabfb08740bd13af7418ceda41d1341cc5d (diff)
downloadsamba-92368833faf51fd56e95a2d646eaae1d697f8e81.tar.gz
samba-92368833faf51fd56e95a2d646eaae1d697f8e81.tar.bz2
samba-92368833faf51fd56e95a2d646eaae1d697f8e81.zip
configure configure.in include/config.h.in lib/replace.c: Added test and replacement
for setlinebuf which apparantly doesn't exist on HPUX 11. include/byteorder.h: rpc_parse/parse_prs.c: Ding Dong the witch is dead ! :-). Ok, I'm happy 'cos I've finally deleted all the *HORRIBLE* DBG_RW_XXX and RW_XXX macros from include/byteorder.h. They were macros that included macros that had conditional macros included. No one understood them (they were the cause of most of the bigendian issue bugs). Finally, I went into parse_prs.c and inlined all of that stuff with regular function calls. They're understandable, they're easy to edit and they don't include macros ! JF - please look at the one comment I added (JF PLEASE CHECK). I have tested this partly with IRIX (a bigendian system) running with AS/U on a Solaris box in SGI's lab, and I've also confirmed these new changes work with W2K (vmware) but there may be the odd bug lurking. Herb, if you could re-checkout and test again with this code that would help. Extra. Fixed bug spotted by the sharp eyes of JF - big endian unicode packet would cause a early truncate of string parsing as we were checking for a char * 0, not a uint16 * 0. Jeremy. (This used to be commit 13765eca71e54aa5d048ce36cd8066b8406777c8)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 3b420f6783..959071673c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -419,7 +419,7 @@ AC_CHECK_FUNCS(strftime sigprocmask sigblock sigaction innetgr setnetgrent getne
AC_CHECK_FUNCS(initgroups select poll rdchk getgrnam getgrent pathconf)
AC_CHECK_FUNCS(setpriv setgidx setuidx setgroups sysconf mktime rename ftruncate stat64 fstat64)
AC_CHECK_FUNCS(lstat64 fopen64 atexit grantpt dup2 lseek64 ftruncate64 readdir64)
-AC_CHECK_FUNCS(fseek64 fseeko64 ftell64 ftello64 setluid getpwanam)
+AC_CHECK_FUNCS(fseek64 fseeko64 ftell64 ftello64 setluid getpwanam setlinebuf)
AC_CHECK_FUNCS(srandom random srand rand setenv usleep strcasecmp fcvt fcvtl)
# syscall() is needed for smbwrapper.