summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorLars Müller <lmuelle@samba.org>2006-02-27 14:10:14 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:10:49 -0500
commit94893f645b25f9e923e32b64da9573123c3f776a (patch)
treeb4b55ceb12233f1a164125956ba1a545a954caf0 /source3/configure.in
parente54786b53543b4667288c64abb55478fddd95061 (diff)
downloadsamba-94893f645b25f9e923e32b64da9573123c3f776a.tar.gz
samba-94893f645b25f9e923e32b64da9573123c3f776a.tar.bz2
samba-94893f645b25f9e923e32b64da9573123c3f776a.zip
r13713: Added installcifsmount and uninstallcifsmount rules for mount.cifs and
unmount.cifs. This is controlled via CIFSMOUNT_PROGS which is set by configure by default to yes on linux systems only. It's possible to disable with --without-cifsmount anyhow. Added ROOTSBINDIR to the Makefile to allow us an install to /sbin and not $prefix/sbin. Configurable with --with-rootsbindir. (This used to be commit a2ab4cc824995cbe172c9179edf9002d17de7f74)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in61
1 files changed, 61 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 3f1600249e..7f38408195 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -22,6 +22,7 @@ fi
# ones...
AC_PREFIX_DEFAULT(/usr/local/samba)
+rootsbindir="/sbin"
lockdir="\${VARDIR}/locks"
piddir="\${VARDIR}/locks"
mandir="\${prefix}/man"
@@ -63,6 +64,22 @@ AC_ARG_WITH(privatedir,
esac])
#################################################
+# set root sbin directory location
+AC_ARG_WITH(rootsbindir,
+[ --with-rootsbindir=DIR Which directory to use for root sbin (/sbin)],
+[ case "$withval" in
+ yes|no)
+ #
+ # Just in case anybody calls it without argument
+ #
+ AC_MSG_WARN([--with-rootsbindir called without argument - will use default])
+ ;;
+ * )
+ rootsbindir="$withval"
+ ;;
+ esac])
+
+#################################################
# set lock directory location
AC_ARG_WITH(lockdir,
[ --with-lockdir=DIR Where to put lock files ($ac_default_prefix/var/locks)],
@@ -201,6 +218,7 @@ AC_SUBST(privatedir)
AC_SUBST(swatdir)
AC_SUBST(bindir)
AC_SUBST(sbindir)
+AC_SUBST(rootsbindir)
dnl Unique-to-Samba variables we'll be playing with.
AC_SUBST(SHELL)
@@ -242,6 +260,9 @@ AC_SUBST(SMBWRAPPER)
AC_SUBST(SMBWRAP_OBJS)
AC_SUBST(SMBWRAP_INC)
AC_SUBST(EXTRA_BIN_PROGS)
+AC_SUBST(CIFSMOUNT_PROGS)
+AC_SUBST(INSTALL_CIFSMOUNT)
+AC_SUBST(UNINSTALL_CIFSMOUNT)
AC_SUBST(EXTRA_SBIN_PROGS)
AC_SUBST(EXTRA_ALL_TARGETS)
AC_SUBST(CONFIG_LIBS)
@@ -3567,6 +3588,46 @@ AC_ARG_WITH(smbmount,
AC_MSG_RESULT(no)
)
+#################################################
+# check for mount- and umount.cifs support
+CIFSMOUNT_PROGS=""
+INSTALL_CIFSMOUNT=""
+UNINSTALL_CIFSMOUNT=""
+AC_MSG_CHECKING(whether to build mount.cifs and umount.cifs)
+AC_ARG_WITH(cifsmount,
+[ --with-cifsmount Include mount.cifs and umount.cifs (Linux only) support (default=yes)],
+[ case "$withval" in
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
+ case "$host_os" in
+ *linux*)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_CIFSMOUNT,1,[Whether to build mount.cifs and umount.cifs])
+ CIFSMOUNT_PROGS="bin/mount.cifs bin/umount.cifs"
+ INSTALL_CIFSMOUNT="installcifsmount"
+ UNINSTALL_CIFSMOUNT="uninstallcifsmount"
+ ;;
+ *)
+ AC_MSG_ERROR(not on a linux system!)
+ ;;
+ esac
+ ;;
+ esac ],
+[ case "$host_os" in
+ *linux*)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_CIFSMOUNT,1,[Whether to build mount.cifs and umount.cifs])
+ CIFSMOUNT_PROGS="bin/mount.cifs bin/umount.cifs"
+ INSTALL_CIFSMOUNT="installcifsmount"
+ UNINSTALL_CIFSMOUNT="uninstallcifsmount"
+ ;;
+ *)
+ AC_MSG_ERROR(not on a linux system!)
+ ;;
+ esac ]
+)
#################################################