summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorDan Sledz <dan.sledz@isilon.com>2009-02-13 12:24:22 -0800
committerSteven Danneman <steven.danneman@isilon.com>2009-02-20 19:39:07 -0800
commitc383022f89a34b83039502cc58178498cc06370e (patch)
tree64202b4165734099e1cf848d181deb19027cf4bc /source3/configure.in
parente311dcff2272968959b4268c2e7aad351443b191 (diff)
downloadsamba-c383022f89a34b83039502cc58178498cc06370e.tar.gz
samba-c383022f89a34b83039502cc58178498cc06370e.tar.bz2
samba-c383022f89a34b83039502cc58178498cc06370e.zip
Introduce a new authentication backend auth_onefs_wb
This new backend is custom tailored to onefs' unique requirements: 1) No fallback logic 2) Does not validate the domain of the user 3) Handles unencrypted passwords
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 9320fb64e4..41140aed34 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1104,6 +1104,7 @@ echo $samba_cv_HAVE_ONEFS
if test x"$samba_cv_HAVE_ONEFS" = x"yes"; then
AC_DEFINE(HAVE_ONEFS,1,[Whether building on Isilon OneFS])
default_shared_modules="$default_shared_modules vfs_onefs vfs_onefs_shadow_copy perfcount_onefs"
+ default_static_modules="$default_static_modules auth_onefs_wb"
ONEFS_LIBS="-lisi_acl -lisi_ecs -lisi_event -lisi_util"
# Need to also add general libs for oplocks support
save_LIBS="$save_LIBS -lisi_ecs -lisi_event -lisi_util -ldevstat"
@@ -6187,6 +6188,7 @@ SMB_SUBSYSTEM(CHARSET,lib/iconv.o)
SMB_MODULE(auth_sam, \$(AUTH_SAM_OBJ), "bin/sam.$SHLIBEXT", AUTH)
SMB_MODULE(auth_unix, \$(AUTH_UNIX_OBJ), "bin/unix.$SHLIBEXT", AUTH)
SMB_MODULE(auth_winbind, \$(AUTH_WINBIND_OBJ), "bin/winbind.$SHLIBEXT", AUTH)
+SMB_MODULE(auth_onefs_wb, \$(AUTH_ONEFS_WB_OBJ), "bin/onefs_wb.$SHLIBEXT", AUTH)
SMB_MODULE(auth_server, \$(AUTH_SERVER_OBJ), "bin/smbserver.$SHLIBEXT", AUTH)
SMB_MODULE(auth_domain, \$(AUTH_DOMAIN_OBJ), "bin/domain.$SHLIBEXT", AUTH)
SMB_MODULE(auth_builtin, \$(AUTH_BUILTIN_OBJ), "bin/builtin.$SHLIBEXT", AUTH)