summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2001-09-21 22:06:03 +0000
committerJeremy Allison <jra@samba.org>2001-09-21 22:06:03 +0000
commitd76dfbb879dc49cb03742f6ed184eb5ef5b75002 (patch)
tree6972c361fc62ca4d876d292866b8165467b6dca2 /source3/configure.in
parentb49a1f01b06724abb66e212f3aa641a1578d3534 (diff)
downloadsamba-d76dfbb879dc49cb03742f6ed184eb5ef5b75002.tar.gz
samba-d76dfbb879dc49cb03742f6ed184eb5ef5b75002.tar.bz2
samba-d76dfbb879dc49cb03742f6ed184eb5ef5b75002.zip
Attempt to make quotas work with RH7.1, and with other Linuxen... This is
*HARD*, dammit ! Jeremy. (This used to be commit 59a4684201fb72989698db5ac8169bd8880bd9a7)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 78a0d2e9af..f8e54f13b1 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1907,6 +1907,26 @@ AC_ARG_WITH(quotas,
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
+ case "$host_os" in
+ *linux*)
+ # Check for kernel 2.4.x quota braindamage...
+ AC_CACHE_CHECK([for linux 2.4.x quota braindamage..],samba_cv_linux_2_4_quota_braindamage, [
+ AC_TRY_COMPILE([#include <stdio.h>
+#include <sys/types.h>
+#include <asm/types.h>
+#include <linux/quota.h>
+#include <mntent.h>
+#include <linux/unistd.h>],[struct mem_dqblk D;],
+ samba_cv_linux_2_4_quota_braindamage=yes,samba_cv_linux_2_4_quota_braindamage=no)])
+if test x"$samba_cv_linux_2_4_quota_braindamage" = x"yes"; then
+ AC_DEFINE(LINUX_QUOTAS_2)
+else
+ AC_DEFINE(LINUX_QUOTAS_1)
+fi
+ ;;
+ *)
+ ;;
+ esac
QUOTAOBJS=smbd/quotas.o
AC_DEFINE(WITH_QUOTAS)
;;