summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2004-11-23 16:35:14 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 10:53:24 -0500
commitdc42a6c3c484d6feaa2a430955a0d565bfc22ecf (patch)
tree558ca07a05e074f4e9dc4ff2f0f1899a2af70097 /source3/configure.in
parent07d8bf0f8fc29c2666edeeec03a7028f219f3e6d (diff)
downloadsamba-dc42a6c3c484d6feaa2a430955a0d565bfc22ecf.tar.gz
samba-dc42a6c3c484d6feaa2a430955a0d565bfc22ecf.tar.bz2
samba-dc42a6c3c484d6feaa2a430955a0d565bfc22ecf.zip
r3925: patch from Thomas Bork <tombork@web.de> to fix configure.in with GNU ld versions that don't output a date string in the --version
(This used to be commit 3bbae21dc9d8147a40cac7962e44fe37630efb40)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in23
1 files changed, 20 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f113450744..09586adcd6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -298,9 +298,26 @@ if test "$ac_cv_prog_gnu_ld" = "yes"; then
ac_cv_gnu_ld_date=`echo $ac_cv_gnu_ld_version | sed -n 's,^.*\([2-9][0-9][0-9][0-9]\)[-]*\([01][0-9]\)[-]*\([0-3][0-9]\).*$,\1\2\3,p'`
changequote([,])dnl
AC_MSG_RESULT(${ac_cv_gnu_ld_date})
- if test "$ac_cv_gnu_ld_date" -lt 20030217; then
- ac_cv_gnu_ld_no_default_allow_shlib_undefined=yes
- fi
+ if test -n "$ac_cv_gnu_ld_date"; then
+ if test "$ac_cv_gnu_ld_date" -lt 20030217; then
+ ac_cv_gnu_ld_no_default_allow_shlib_undefined=yes
+ fi
+ else
+ AC_MSG_CHECKING(GNU ld release version)
+ changequote(,)dnl
+ ac_cv_gnu_ld_vernr=`echo $ac_cv_gnu_ld_version | sed -n 's,^.*\([1-9][0-9]*\.[0-9][0-9]*\).*$,\1,p'`
+ ac_cv_gnu_ld_vernr_major=`echo $ac_cv_gnu_ld_vernr | cut -d '.' -f 1`
+ ac_cv_gnu_ld_vernr_minor=`echo $ac_cv_gnu_ld_vernr | cut -d '.' -f 2`
+ changequote([,])dnl
+ AC_MSG_RESULT(${ac_cv_gnu_ld_vernr})
+ AC_MSG_CHECKING(GNU ld release version major)
+ AC_MSG_RESULT(${ac_cv_gnu_ld_vernr_major})
+ AC_MSG_CHECKING(GNU ld release version minor)
+ AC_MSG_RESULT(${ac_cv_gnu_ld_vernr_minor})
+ if test "$ac_cv_gnu_ld_vernr_major" -lt 2 || test "$ac_cv_gnu_ld_vernr_minor" -lt 14; then
+ ac_cv_gnu_ld_no_default_allow_shlib_undefined=yes
+ fi
+ fi
fi
dnl needed before AC_TRY_COMPILE