summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2001-04-14 19:46:28 +0000
committerJeremy Allison <jra@samba.org>2001-04-14 19:46:28 +0000
commited449b8ca7697d64ab3cfe8289287dd18566c91e (patch)
tree34541fbdd298c93db6f14d288da98321f69f2aa1 /source3/configure.in
parent548ca26bd56467f7dafaf277e4d42adeb54fb557 (diff)
downloadsamba-ed449b8ca7697d64ab3cfe8289287dd18566c91e.tar.gz
samba-ed449b8ca7697d64ab3cfe8289287dd18566c91e.tar.bz2
samba-ed449b8ca7697d64ab3cfe8289287dd18566c91e.zip
Added POSIX_ACL support for *BSD. Patch from jedgar@fxp.org. Changed
a bit to use AC_TRY_LINK to ensure functions are available for link instead of AC_TRY_COMPILE. Jeremy. (This used to be commit c23628746342b6afa28cb34b0b4eaa61189ad390)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in22
1 files changed, 15 insertions, 7 deletions
diff --git a/source3/configure.in b/source3/configure.in
index c8270d2d5c..16f7f0af1a 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2075,16 +2075,24 @@ AC_ARG_WITH(acl-support,
AC_DEFINE(HAVE_IRIX_ACLS)
;;
*)
- AC_CHECK_LIB(acl,acl_get_file)
- AC_CACHE_CHECK([for ACL support],samba_cv_HAVE_POSIX_ACLS,[
- AC_TRY_COMPILE([#include <sys/types.h>
+ AC_CHECK_LIB(acl,acl_get_file)
+ AC_CACHE_CHECK([for ACL support],samba_cv_HAVE_POSIX_ACLS,[
+ AC_TRY_LINK([#include <sys/types.h>
#include <sys/acl.h>],
[ acl_t acl; int entry_id; acl_entry_t *entry_p; return acl_get_entry( acl, entry_id, entry_p);],
samba_cv_HAVE_POSIX_ACLS=yes,samba_cv_HAVE_POSIX_ACLS=no)])
- if test x"$samba_cv_HAVE_POSIX_ACLS" = x"yes"; then
- AC_MSG_RESULT(Using posix ACLs)
- AC_DEFINE(HAVE_POSIX_ACLS)
- fi
+ if test x"$samba_cv_HAVE_POSIX_ACLS" = x"yes"; then
+ AC_MSG_RESULT(Using posix ACLs)
+ AC_DEFINE(HAVE_POSIX_ACLS)
+ AC_CACHE_CHECK([for acl_get_perm_np],samba_cv_HAVE_ACL_GET_PERM_NP,[
+ AC_TRY_LINK([#include <sys/types.h>
+#include <sys/acl.h>],
+[ acl_permset_t permset_d; acl_perm_t perm; return acl_get_perm_np( permset_d, perm);],
+samba_cv_HAVE_ACL_GET_PERM_NP=yes,samba_cv_HAVE_ACL_GET_PERM_NP=no)])
+ if test x"$samba_cv_HAVE_ACL_GET_PERM_NP" = x"yes"; then
+ AC_DEFINE(HAVE_ACL_GET_PERM_NP)
+ fi
+ fi
AC_CACHE_CHECK([for XFS ACL support],samba_cv_HAVE_XFS_ACLS,[
AC_TRY_COMPILE([#include <sys/types.h>
#include <acl/acl.h>],