summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2005-07-15 21:36:00 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:00:07 -0500
commitf5bf5765af07f04ff6fcf5615c2e09fc468aff5f (patch)
tree4127933d7cede9ce74ea2965fe9085a1df0c273e /source3/configure.in
parent787e526652b2f754ca9441a6fdf8e0745ac4d54a (diff)
downloadsamba-f5bf5765af07f04ff6fcf5615c2e09fc468aff5f.tar.gz
samba-f5bf5765af07f04ff6fcf5615c2e09fc468aff5f.tar.bz2
samba-f5bf5765af07f04ff6fcf5615c2e09fc468aff5f.zip
r8510: Don't include the valgrind headers on 64bit linux systems.
Several incarnations of gcc bork with Compiling dynconfig.c /tmp/ccXd94O5.s: Assembler messages: /tmp/ccXd94O5.s:1202: Error: suffix or operands invalid for `mov' /tmp/ccXd94O5.s:1289: Error: suffix or operands invalid for `mov'` Thanks to Bent Vangli for the the leg work and suggestions. (This used to be commit 318fe7ba0093c4a94e9f4f5c8ce7a2f5d1078e26)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 8ac3d20705..928e57baac 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -752,6 +752,18 @@ CPPFLAGS="$old_CPPFLAGS"
# subdirectory of headers.
AC_CHECK_HEADERS(valgrind.h valgrind/valgrind.h valgrind/memcheck.h)
+/* check for linux on amd64 since valgrind is not quite there yet */
+case "$host_os" in
+ *linux*)
+ case "$UNAME_P" in
+ *x86_64*)
+ AC_DEFINE(HAVE_64BIT_LINUX,1,[Whether we are running on 64bit linux])
+ ;;
+ esac
+ ;;
+esac
+
+
#
# HPUX has a bug in that including shadow.h causes a re-definition of MAXINT.
# This causes configure to fail to detect it. Check for shadow separately on HPUX.