summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2001-02-25 00:24:54 +0000
committerJeremy Allison <jra@samba.org>2001-02-25 00:24:54 +0000
commitf93bb0801ccd66a6a3709ad98afb3758ffd0c1d4 (patch)
treec0413e3f95270041843d95f836a86bd791a7f063 /source3/configure.in
parent3699948e97bc2a8d108bb4343d382b4c9ead5533 (diff)
downloadsamba-f93bb0801ccd66a6a3709ad98afb3758ffd0c1d4.tar.gz
samba-f93bb0801ccd66a6a3709ad98afb3758ffd0c1d4.tar.bz2
samba-f93bb0801ccd66a6a3709ad98afb3758ffd0c1d4.zip
rpc_client/cli_netlogon.c: Fixed incorrect printf.
Added Solaris ACL support. Jeremy. (This used to be commit f0d11b6997cc46a0210adef8cf572cf8b7e2467a)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in41
1 files changed, 26 insertions, 15 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 7eba74d710..2ad8b2d937 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1924,35 +1924,46 @@ if test "x$with_spinlocks" = "xyes"; then
fi
#################################################
-# check for POSIX ACL support
+# check for ACL support
-AC_MSG_CHECKING(whether to support POSIX ACLs)
-AC_ARG_WITH(posix-acls,
-[ --with-posix-acls Include POSIX ACL support
- --without-posix-acls Don't include POSIX ACL support (default)],
+AC_MSG_CHECKING(whether to support ACLs)
+AC_ARG_WITH(acl-support,
+[ --with-acl-support Include ACL support
+ --without-acl-support Don't include ACL support (default)],
[ case "$withval" in
yes)
- AC_CHECK_LIB(acl,acl_get_file)
-AC_CACHE_CHECK([for POSIX ACL support],samba_cv_HAVE_POSIX_ACLS,[
-AC_TRY_COMPILE([#include <sys/types.h>
+ case "$host_os" in
+ *unixware*)
+ AC_MSG_RESULT(Using SVR4 ACLs)
+ AC_DEFINE(HAVE_UNIXWARE_ACLS)
+ ;;
+ *solaris*)
+ AC_MSG_RESULT(Using solaris ACLs)
+ AC_DEFINE(HAVE_SOLARIS_ACLS)
+ ;;
+ *)
+ AC_CHECK_LIB(acl,acl_get_file)
+ AC_CACHE_CHECK([for ACL support],samba_cv_HAVE_POSIX_ACLS,[
+ AC_TRY_COMPILE([#include <sys/types.h>
#include <sys/acl.h>],
[ acl_t acl; int entry_id; acl_entry_t *entry_p; return acl_get_entry( acl, entry_id, entry_p);],
samba_cv_HAVE_POSIX_ACLS=yes,samba_cv_HAVE_POSIX_ACLS=no)])
-if test x"$samba_cv_HAVE_POSIX_ACLS" = x"yes"; then
- AC_MSG_RESULT(yes)
- AC_DEFINE(HAVE_POSIX_ACLS)
-fi
- ;;
+ if test x"$samba_cv_HAVE_POSIX_ACLS" = x"yes"; then
+ AC_MSG_RESULT(Using posix ACLs)
+ AC_DEFINE(HAVE_POSIX_ACLS)
+ fi
+ ;;
+ esac
+ ;;
*)
AC_MSG_RESULT(no)
AC_DEFINE(HAVE_NO_ACLS)
;;
esac ],
- AC_MSG_RESULT(no)
AC_DEFINE(HAVE_NO_ACLS)
+ AC_MSG_RESULT(no)
)
-
echo "checking configure summary"
AC_TRY_RUN([#include "${srcdir-.}/tests/summary.c"],
echo "configure OK";,