summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>1998-07-29 05:05:36 +0000
committerAndrew Tridgell <tridge@samba.org>1998-07-29 05:05:36 +0000
commitfb08c34cf3950f994701a9c98c89670f6346f7ab (patch)
treed24bacbacb7c84d89c52c2e7742a4fe4bea537b2 /source3/configure.in
parent73dc9870af658dfe467e33ecefe2d740a0d0dbb0 (diff)
downloadsamba-fb08c34cf3950f994701a9c98c89670f6346f7ab.tar.gz
samba-fb08c34cf3950f994701a9c98c89670f6346f7ab.tar.bz2
samba-fb08c34cf3950f994701a9c98c89670f6346f7ab.zip
get rid of the runtime test for broken getgroups() and add a compile
time test instead. This also allows us to get rid of the igroups element of a couple of structures. (This used to be commit 8b25fe734166b76ceebf8d9543c706ebe0fddc96)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 883085b3e1..5cdc3425d6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -211,6 +211,11 @@ if test "$ac_cv_lib_socket_connect" = "yes" ||
AC_DEFINE(HAVE_CONNECT)
fi])
+echo $ac_n "checking for broken getgroups ... $ac_c"
+AC_TRY_RUN([#include "tests/getgroups.c"],
+ echo yes;AC_DEFINE(HAVE_BROKEN_GETGROUPS),
+ echo no)
+
echo $ac_n "checking for root ... $ac_c"
AC_TRY_RUN([main() { exit(getuid() != 0); }],