summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2008-07-07 00:41:23 +0200
committerMichael Adam <obnox@samba.org>2008-07-07 20:34:02 +0200
commitfc54fc52f49c523ec355c882ea72fc2ebed3b67d (patch)
treea52c643412dcce5e2c9dab4f79c74bbf1163557f /source3/configure.in
parent175497e14b469c2f8d8724a3cc63585c23cd87e3 (diff)
downloadsamba-fc54fc52f49c523ec355c882ea72fc2ebed3b67d.tar.gz
samba-fc54fc52f49c523ec355c882ea72fc2ebed3b67d.tar.bz2
samba-fc54fc52f49c523ec355c882ea72fc2ebed3b67d.zip
build: handle libsmbsharemodes by SMB_LIBRARY() and correctly create SONAME file.
Create libsmbsharemodes.so as a symlink. Michael (This used to be commit 1157048146084e9ab34d7c2e77e8d00b22df53a4)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in48
1 files changed, 1 insertions, 47 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 2ac44b36f0..b5c372974c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -95,11 +95,6 @@ AC_SUBST(WINBIND_LIBS)
AC_SUBST(LIBSAMBAUTIL_SHARED)
-AC_SUBST(INSTALL_LIBSMBSHAREMODES)
-AC_SUBST(UNINSTALL_LIBSMBSHAREMODES)
-AC_SUBST(LIBSMBSHAREMODES_SHARED)
-AC_SUBST(LIBSMBSHAREMODES)
-
AC_SUBST(PRINT_LIBS)
AC_SUBST(AUTH_LIBS)
AC_SUBST(ACL_LIBS)
@@ -4686,6 +4681,7 @@ SMB_LIBRARY(talloc)
SMB_LIBRARY(tdb)
SMB_LIBRARY(netapi)
SMB_LIBRARY(smbclient)
+SMB_LIBRARY(smbsharemodes)
#################################################
@@ -4721,48 +4717,6 @@ AC_ARG_WITH(libaddns,
)
-INSTALL_LIBSMBSHAREMODES=
-LIBSMBSHAREMODES_SHARED=
-LIBSMBSHAREMODES=
-AC_MSG_CHECKING(whether to build the libsmbsharemodes shared library)
-AC_ARG_WITH(libsmbsharemodes,
-[AS_HELP_STRING([--with-libsmbsharemodes], [Build the libsmbsharemodes shared library (default=yes if shared libs supported)])],
-[ case "$withval" in
- no)
- AC_MSG_RESULT(no)
- ;;
- *)
- if test $BLDSHARED = true; then
- LIBSMBSHAREMODES_SHARED=bin/libsmbsharemodes.$SHLIBEXT
- LIBSMBSHAREMODES=libsmbsharemodes
- AC_MSG_RESULT(yes)
- else
- enable_static=yes
- AC_MSG_RESULT(no shared library support -- will supply static library)
- fi
- if test $enable_static = yes; then
- LIBSMBSHAREMODES=libsmbsharemodes
- fi
- INSTALL_LIBSMBSHAREMODES=installlibsmbsharemodes
- UNINSTALL_LIBSMBSHAREMODES=uninstalllibsmbsharemodes
- ;;
- esac ],
-[
-# if unspecified, default is to build it if possible.
- if test $BLDSHARED = true; then
- LIBSMBSHAREMODES_SHARED=bin/libsmbsharemodes.$SHLIBEXT
- LIBSMBSHAREMODES=libsmbsharemodes
- AC_MSG_RESULT(yes)
- else
- enable_static=yes
- AC_MSG_RESULT(no shared library support -- will supply static library)
- fi
- if test $enable_static = yes; then
- LIBSMBSHAREMODES=libsmbsharemodes
- fi]
- INSTALL_LIBSMBSHAREMODES=installlibsmbsharemodes
-)
-
#################################################
# these tests are taken from the GNU fileutils package