summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2008-02-21 14:07:45 +0100
committerMichael Adam <obnox@samba.org>2008-02-21 14:07:45 +0100
commit0d7f555335f03219b3bfb66d8caffbedc97f585a (patch)
treeb1c88c758a624ad3c4fc8a14dc86900a2966bb3a /source3/configure.in
parentd29c816b6195f9d1ef394830a6438123a0fb3afd (diff)
downloadsamba-0d7f555335f03219b3bfb66d8caffbedc97f585a.tar.gz
samba-0d7f555335f03219b3bfb66d8caffbedc97f585a.tar.bz2
samba-0d7f555335f03219b3bfb66d8caffbedc97f585a.zip
Move the definition of SMB_LIBRARY to aclocal.m4.
Michael (This used to be commit 4724b13ed8dce4721f95979803ba32f815ceaf1a)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in67
1 files changed, 0 insertions, 67 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 14110da52b..78f0901c53 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -4710,73 +4710,6 @@ AC_ARG_WITH([static-libs],
[])
-
-dnl SMB_LIBRARY(name)
-dnl
-dnl configure build and use of an (internal) shared library
-dnl
-AC_DEFUN([SMB_LIBRARY],
-[
-m4_pushdef([LIBNAME], [lib$1])
-m4_pushdef([LIBUC], [m4_toupper(LIBNAME)])
-m4_pushdef([LIBLIBS], [-l$1])
-
-LIBUC[_SHARED_TARGET]=bin/LIBNAME.$SHLIBEXT
-LIBUC[_STATIC_TARGET]=bin/LIBNAME.a
-LIBUC[_SHARED]=
-LIBUC[_STATIC]=
-LIBUC[_LIBS]=
-
-AC_SUBST(LIBUC[_SHARED_TARGET])
-AC_SUBST(LIBUC[_STATIC_TARGET])
-AC_SUBST(LIBUC[_SHARED])
-AC_SUBST(LIBUC[_STATIC])
-AC_SUBST(LIBUC[_LIBS])
-
-AC_MSG_CHECKING([whether to build the LIBNAME shared library])
-AC_ARG_WITH(LIBNAME,
-[AS_HELP_STRING([--with-LIBNAME],
- [Build the LIBNAME shared library (default=yes if shared libs supported)])],
-[
-case "$withval" in
- *)
- AC_MSG_RESULT(no)
- build_lib=no
- ;;
- yes)
- build_lib=yes
- ;;
-esac
-],
-[
-# if unspecified, default is to build it if possible.
-build_lib=yes
-]
-)
-
-if eval test x"$build_lib" = "xyes" -a $BLDSHARED = true; then
- LIBUC[_SHARED]=$LIBUC[_SHARED_TARGET]
- AC_MSG_RESULT(yes)
- if test x"$USESHARED" != x"true" -o x"$LINK_LIBUC" = "xSTATIC" ; then
- LIBUC[_STATIC]=$LIBUC[_STATIC_TARGET]
- else
- LIBUC[_LIBS]=LIBLIBS
- fi
-else
- enable_static=yes
- AC_MSG_RESULT(no shared library support -- will supply static library)
-fi
-if test $enable_static = yes; then
- LIBUC[_STATIC]=$LIBUC[_STATIC_TARGET]
-fi
-
-m4_popdef([LIBNAME])
-m4_popdef([LIBUC])
-m4_popdef([LIBLIBS])
-
-])
-
-
SMB_LIBRARY(talloc)
SMB_LIBRARY(tdb)
SMB_LIBRARY(netapi)