summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAlexander Bokovoy <ab@samba.org>2003-02-15 22:51:15 +0000
committerAlexander Bokovoy <ab@samba.org>2003-02-15 22:51:15 +0000
commit22c875943d2e8efe87c5f5049ace37d1135eb187 (patch)
tree1642845d931883a217a5ef2237d9f7dcbfa5d862 /source3/configure.in
parent88a4d79e7b771ec8bcc903a7406e15cf4aeea248 (diff)
downloadsamba-22c875943d2e8efe87c5f5049ace37d1135eb187.tar.gz
samba-22c875943d2e8efe87c5f5049ace37d1135eb187.tar.bz2
samba-22c875943d2e8efe87c5f5049ace37d1135eb187.zip
Third-party configuration scripts may produce undesirable additions to CFLAGS/CPPFLAGS
and LIBS/LDFALGS. In particular, they often don't check where the appropriate libraries were installed and pass -I/usr/include and -L/usr/lib as part of CFLAGS/LDFLAGS. While the latter isn't dangerous, passing system include directory through -I lead to change of its status in CPP from system to user-defined in many cases. This patch cleans up CFLAGS/CPPFLAGS from errorenous -I/usr/include and LIBS/LDFLAGS from -L/usr/lib. This is done as two m4 macros which are called before AC_OUTPUT. (This used to be commit 643172ac1a9b53823d704690eb03120074bbef78)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index c999326b15..25cc8bd250 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3373,6 +3373,14 @@ AC_TRY_RUN([#include "${srcdir-.}/tests/summary.c"],
builddir=`pwd`
AC_SUBST(builddir)
+dnl Remove -L/usr/lib/? from LDFLAGS and LIBS
+LIB_REMOVE_USR_LIB(LDFLAGS)
+LIB_REMOVE_USR_LIB(LIBS)
+
+dnl Remove -I/usr/include/? from CFLAGS and CPPFLAGS
+CFLAGS_REMOVE_USR_INCLUDE(CFLAGS)
+CFLAGS_REMOVE_USR_INCLUDE(CPPFLAGS)
+
AC_OUTPUT(include/stamp-h Makefile script/findsmb)
#################################################