summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2003-04-02 15:08:31 +0000
committerJelmer Vernooij <jelmer@samba.org>2003-04-02 15:08:31 +0000
commit388af6585777b529877848b97c2b9c2fa9e35e06 (patch)
tree912f70bd5bcd12fc00c32fbf9198ca84975ae79f /source3/configure.in
parent75c1bf29a8d14e2d0458b8f89e347a5e374d3ea5 (diff)
downloadsamba-388af6585777b529877848b97c2b9c2fa9e35e06.tar.gz
samba-388af6585777b529877848b97c2b9c2fa9e35e06.tar.bz2
samba-388af6585777b529877848b97c2b9c2fa9e35e06.zip
Only link in popt when we need it
(This used to be commit a5a980eb3efb37a6becacf043692361bdb4174b0)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index d0c3e8e1fd..266dffa38b 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3343,12 +3343,15 @@ AC_MSG_CHECKING(whether to use included popt)
if test x"$INCLUDED_POPT" = x"yes"; then
AC_MSG_RESULT(yes)
BUILD_POPT='$(POPT_OBJS)'
+ POPTLIBS='$(POPT_OBJS)'
FLAGS1="-I$srcdir/popt"
else
AC_MSG_RESULT(no)
- BUILD_POPT="-lpopt"
+ BUILD_POPT=""
+ POPTLIBS="-lpopt"
fi
AC_SUBST(BUILD_POPT)
+AC_SUBST(POPTLIBS)
AC_SUBST(FLAGS1)
#################################################