summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2008-02-19 16:45:38 +0100
committerMichael Adam <obnox@samba.org>2008-02-19 17:39:40 +0100
commit3b3b80a3653863533c9a20833e9bf75330be5c0a (patch)
tree61973f42bb9f01ec6b997b20b848bb49bc5a5bbb /source3/configure.in
parent53d5624205b684d8c7a47d6b4bfb5ac6aceed998 (diff)
downloadsamba-3b3b80a3653863533c9a20833e9bf75330be5c0a.tar.gz
samba-3b3b80a3653863533c9a20833e9bf75330be5c0a.tar.bz2
samba-3b3b80a3653863533c9a20833e9bf75330be5c0a.zip
configure: move debug check to developer check
...thereby grouping test checks and debug/developer checks together, respectively. Michael (This used to be commit bf1bb2c0906dd5e518c3f35ef97d69eba0e2efdf)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4ed1782301..cc71ccfc18 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -267,15 +267,6 @@ AC_SUBST(cachedir)
AC_SUBST(rootsbindir)
AC_SUBST(pammodulesdir)
-## check for --enable-debug first before checking CFLAGS before
-## so that we don't mix -O and -g
-debug=no
-AC_ARG_ENABLE(debug,
-[AS_HELP_STRING([--enable-debug], [Turn on compiler debugging information (default=no)])],
- [if eval "test x$enable_debug = xyes"; then
- debug=yes
- fi])
-
#################################################
# set prefix for 'make test'
selftest_prefix="./"
@@ -311,6 +302,15 @@ AC_ARG_WITH(smbtorture4_path,
esac
])
+## check for --enable-debug first before checking CFLAGS before
+## so that we don't mix -O and -g
+debug=no
+AC_ARG_ENABLE(debug,
+[AS_HELP_STRING([--enable-debug], [Turn on compiler debugging information (default=no)])],
+ [if eval "test x$enable_debug = xyes"; then
+ debug=yes
+ fi])
+
developer=no
AC_ARG_ENABLE(developer, [AS_HELP_STRING([--enable-developer], [Turn on developer warnings and debugging (default=no)])],
[if eval "test x$enable_developer = xyes"; then