summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2003-04-26 11:48:16 +0000
committerJelmer Vernooij <jelmer@samba.org>2003-04-26 11:48:16 +0000
commit3f3f30549cd9aa393c73c0ad6c9ad8ed6325bd6a (patch)
treecdc7343cc512fa4f10f95fd366c08629e19d17b8 /source3/configure.in
parentd46f29766ffc7d4cd368727ba6eaf00745e242d9 (diff)
downloadsamba-3f3f30549cd9aa393c73c0ad6c9ad8ed6325bd6a.tar.gz
samba-3f3f30549cd9aa393c73c0ad6c9ad8ed6325bd6a.tar.bz2
samba-3f3f30549cd9aa393c73c0ad6c9ad8ed6325bd6a.zip
Fix the weird charset and build it by default for ./configure -enable-developer
(This used to be commit 8d17a4dc2142aa816200f3f91c7f60c3f2c5888c)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 00493b9f71..72df318580 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -247,13 +247,14 @@ dnl Add modules that have to be built by default here
dnl These have to be built static:
default_static_modules="pdb_smbpasswd pdb_tdbsam pdb_unix rpc_lsa rpc_samr rpc_reg rpc_wks rpc_net rpc_dfs rpc_srv rpc_spoolss auth_rhosts auth_sam auth_unix auth_winbind auth_server auth_domain auth_builtin idmap_winbind"
+dnl These are preferably build shared, and static if dlopen() is not available
+default_shared_modules="vfs_recycle vfs_audit vfs_extd_audit vfs_netatalk vfs_fake_perms"
+
if test "x$enable_developer" = xyes; then
default_static_modules="$default_static_modules rpc_echo"
+ default_shared_modules="$default_shared_modules charset_weird"
fi
-dnl These are preferably build shared, and static if dlopen() is not available
-default_shared_modules="vfs_recycle vfs_audit vfs_extd_audit vfs_netatalk vfs_fake_perms"
-
#
# Config CPPFLAG settings for strange OS's that must be set
# before other tests.
@@ -3467,7 +3468,7 @@ SMB_MODULE(rpc_samr, \$(RPC_SAMR_OBJ), "bin/librpc_samr.$SHLIBEXT", RPC)
SMB_MODULE(rpc_echo, \$(RPC_ECHO_OBJ), "bin/librpc_echo.$SHLIBEXT", RPC)
SMB_SUBSYSTEM(RPC)
-SMB_MODULE(charset_weird, modules/developer.o, "bin/developer.$SHLIBEXT", CHARSET)
+SMB_MODULE(charset_weird, modules/weird.o, "bin/weird.$SHLIBEXT", CHARSET)
SMB_SUBSYSTEM(CHARSET)
SMB_MODULE(auth_rhosts, \$(AUTH_RHOSTS_OBJ), "bin/rhosts.$SHLIBEXT", AUTH)