summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2003-01-16 02:39:58 +0000
committerJeremy Allison <jra@samba.org>2003-01-16 02:39:58 +0000
commit4375fe73ba32db2682cedf9c7b68a269e3c17f6e (patch)
treebaf66ab129769d67b6f538aac6323b02ddc27fb7 /source3/configure.in
parentf0e282ebf3e459c559bfc08f3e21fdebb2515621 (diff)
downloadsamba-4375fe73ba32db2682cedf9c7b68a269e3c17f6e.tar.gz
samba-4375fe73ba32db2682cedf9c7b68a269e3c17f6e.tar.bz2
samba-4375fe73ba32db2682cedf9c7b68a269e3c17f6e.zip
Fist part of fixes to make us compile with Heimdal. Don't explicitly
detect for now, I still have vague hopes of hiding the differences between MIT and Heimdal with a compatibility layer.... Jeremy. (This used to be commit a776fbef3244ae82a17c57a7f62de115fd023c86)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 7e3ec6a256..ad778bf88d 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2032,12 +2032,15 @@ fi
# now check for gssapi headers. This is also done here to allow for
# different kerberos include paths
- AC_CHECK_HEADERS(gssapi/gssapi_generic.h gssapi/gssapi.h)
+ AC_CHECK_HEADERS(gssapi.h gssapi/gssapi_generic.h gssapi/gssapi.h)
##################################################################
# we might need the k5crypto and com_err libraries on some systems
AC_CHECK_LIB(com_err, _et_list, [LIBS="$LIBS -lcom_err"])
AC_CHECK_LIB(k5crypto, krb5_encrypt_data, [LIBS="$LIBS -lk5crypto"])
+ # Heimdal checks.
+ AC_CHECK_LIB(crypto, des_set_key, [LIBS="$LIBS -lcrypto"])
+ AC_CHECK_LIB(asn1, copy_Authenticator, [LIBS="$LIBS -lasn1 -lroken"])
########################################################
# now see if we can find the krb5 libs in standard paths
@@ -2049,6 +2052,9 @@ fi
# now see if we can find the gssapi libs in standard paths
AC_CHECK_LIB(gssapi_krb5, gss_display_status, [LIBS="$LIBS -lgssapi_krb5";
AC_DEFINE(HAVE_GSSAPI,1,[Whether GSSAPI is available])])
+ # Heimdal checks.
+ AC_CHECK_LIB(gssapi, gss_display_status, [LIBS="$LIBS -lgssapi";
+ AC_DEFINE(HAVE_GSSAPI,1,[Whether GSSAPI is available])])
fi
########################################################