summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2008-06-09 10:27:12 +0200
committerStefan Metzmacher <metze@samba.org>2008-06-09 11:04:56 +0200
commit4461f0a6ee353e206f4f14f1ff887a0f5f0a6dfa (patch)
treea5f386b42cbf726688723f075efc739e2313f2b8 /source3/configure.in
parent7f70c126b218a6a7b4e6d2f00df08dd365072d53 (diff)
downloadsamba-4461f0a6ee353e206f4f14f1ff887a0f5f0a6dfa.tar.gz
samba-4461f0a6ee353e206f4f14f1ff887a0f5f0a6dfa.tar.bz2
samba-4461f0a6ee353e206f4f14f1ff887a0f5f0a6dfa.zip
configure: fix warnings with autoconf-2.62 rename SMB_BUILD_ => samba_cv_
AC_CACHE_VAL() variables must contain _cv_ to be cached. metze (This used to be commit 89663ab4d10586b96807c56de53fd60d2488093c)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 6d9830d712..b3e448f21c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -337,7 +337,7 @@ fi
# and don't truncate the values to INT_MAX
# a runtime test is needed here
AC_SUBST(PIDL_ARGS)
-AC_CACHE_CHECK([that the C compiler understands negative enum values],SMB_BUILD_CC_NEGATIVE_ENUM_VALUES, [
+AC_CACHE_CHECK([that the C compiler understands negative enum values],samba_cv_CC_NEGATIVE_ENUM_VALUES, [
AC_TRY_RUN(
[
#include <stdio.h>
@@ -358,8 +358,8 @@ AC_CACHE_CHECK([that the C compiler understands negative enum values],SMB_BUILD_
return 0;
}
],
- SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes,SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=no)])
-if test x"$SMB_BUILD_CC_NEGATIVE_ENUM_VALUES" != x"yes"; then
+ samba_cv_CC_NEGATIVE_ENUM_VALUES=yes,samba_cv__CC_NEGATIVE_ENUM_VALUES=no)])
+if test x"$samba_cv_CC_NEGATIVE_ENUM_VALUES" != x"yes"; then
AC_MSG_WARN([using --unit-enums for pidl])
PIDL_ARGS="$PIDL_ARGS --uint-enums"
fi