summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2007-05-23 20:46:07 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:22:45 -0500
commit4b04b843affb065f527ea4ee8d6a68b7947ed0b6 (patch)
treeae9abd267d6e286de67cdb2e35d13524609e3953 /source3/configure.in
parent38daf36d124fbec74afba3a834481001d8000bc6 (diff)
downloadsamba-4b04b843affb065f527ea4ee8d6a68b7947ed0b6.tar.gz
samba-4b04b843affb065f527ea4ee8d6a68b7947ed0b6.tar.bz2
samba-4b04b843affb065f527ea4ee8d6a68b7947ed0b6.zip
r23097: Add a new configure option to disable building SWAT (it is still built by
default). (This used to be commit 910d498a0e44d1c2b76ccddef0cf05e693cf580e)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 3716299d9e..04baf8aafb 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -338,6 +338,21 @@ AC_LIBREPLACE_CC_CHECKS
m4_include(lib/socket_wrapper/config.m4)
+
+AC_ARG_ENABLE(swat,
+[ --enable-swat Build the SWAT tool (default=yes)],
+[
+ case "$enable_swat" in
+ no) ;;
+ *)
+ SWAT_SBIN_TARGETS='bin/swat$(EXEEXT)'
+ SWAT_INSTALL_TARGETS=installswat
+ ;;
+ esac
+ AC_SUBST(SWAT_SBIN_TARGETS)
+ AC_SUBST(SWAT_INSTALL_TARGETS)
+])
+
#################################################
# set prefix for 'make test'
selftest_prefix="./"